Results 1 to 4 of 4
  1. #1

    boost failsafe+cracked block

    I have been battling a boost failsafe issue for the last year. I finally found the concern, the block is cracked along the bottom of the case on the intake side parallel to the bottom of the waterjacket. The knock sensor picked up on this under full boost and then it would go into failsafe. shut it off and restart and it would run fine for 10 seconds at WOT then would set again. Finally found concern when flushing one day and noticed water coming out from behind the starter!. My question is, has anyone else had this happen? Also does anyone out there have a block for sale?


  2. #2
    Moderator
    I build Horsepower
    NitroShark's Avatar
    Join Date
    Jan 2006
    Location
    Greenville,SC
    Posts
    1,388
    +1
    13
    Been there done that... usually it's just cracked on the water jacket side. Tig weld it up and go on. Most likely caused by detonation.

    Shawn

  3. #3
    I have tried to have it welded, crack seems to grow. It is, only on the outer water jacket. I assumed that it was caused by a friend sucking up some weeds and driving it for too long, overheating and then clearing the "plug", while still very hot and starting it back up letting cold water in. I also found the cam pulse generator on this was leaking oil thruogh the harness all the way to the ecm. It has been replaced as well. Could it be that caused the detination, leading to this concern?. Since I ride out in the ocean mainly I would still like a new block if anyone has one out there. Shawn If i had it welded and it still leaks a little, how do you fell about Devcon to seal the rest? I have had a few recommend this, but it sounds a bit "mickey mouse" to me.

  4. #4
    Moderator
    I build Horsepower
    NitroShark's Avatar
    Join Date
    Jan 2006
    Location
    Greenville,SC
    Posts
    1,388
    +1
    13
    You need to vee- grind the weld and prepare it properly. Once tig welded correctly, you will not need "devcon" I've done quite a few this way and they work as new.

    Shawn

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Bought a 2008 FX SHO 22hrs cracked block? Advice needed
    By wielandgeorg in forum Yamaha PWC Performance (4-stroke)
    Replies: 36
    Last Post: 07-21-2015, 09:48 AM
  2. Blown SC and maybe cracked block? Please HELP!
    By Tmlp103 in forum 4-Tec Performance
    Replies: 45
    Last Post: 03-27-2015, 12:54 AM
  3. Which should i go with? SL650 with cracked block or SL750 with burned wires?
    By Ken Townsend in forum Polaris Open Discussion
    Replies: 5
    Last Post: 09-12-2014, 09:03 AM
  4. Replies: 16
    Last Post: 07-31-2014, 09:28 AM
  5. RRFPR and boost gauge tap block off
    By bruinsrme in forum 4-Tec Performance
    Replies: 6
    Last Post: 05-05-2008, 12:26 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •