Results 1 to 4 of 4
  1. #1

    HELP. ?overheating problem?

    My ski runs like a top when connected to flushing hose or when tied to the dock. However when it starts moving through the water it runs for a short time then shuts down. It then restarts but seems to have rpm limiting, so just idles. No warning messages or lights are coming on. Once it cools down, it runs good again.
    This is a 2002 Polaris Virage i. ANY help would be greatly appreciated.

  2. #2
    83Gator's Avatar
    Join Date
    Jul 2008
    St. Amant, LA
    John, welcome to the forum. If a mod doesn't soon move your post, I suggest you ask it in the correct section via this link: Good luck w/your issue.

  3. #3
    Thanks. Haven't figured out this forum thing yet!

  4. #4
    Pain is fear leaving your body.... rlovebk's Avatar
    Join Date
    Aug 2008
    So. Cal.
    The guys on the Polaris section are the most helpful bunch anywhere. Post it up over there and be prepared to recieve more support and help than you could imagine.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Overheating problem 05 GTX ltd
    By bigrich007 in forum 4-Tec Performance
    Replies: 12
    Last Post: 12-24-2007, 03:59 PM
  2. Help With Problems!
    By RDH in forum Yamaha PWC Performance (2-stroke)
    Replies: 48
    Last Post: 05-15-2007, 05:43 PM
  3. Need Help, RXP problems, Plug pictures
    By Water4fire in forum 4-Tec Performance
    Replies: 32
    Last Post: 04-26-2007, 10:38 PM
  4. Solved Riva Level 2 Overheating Problem
    By RXDI2 in forum 4-Tec Performance
    Replies: 16
    Last Post: 07-11-2006, 05:03 AM
  5. Help, having problems with my 2005 RXT, low hours
    By 05rxt in forum 4-Tec Performance
    Replies: 6
    Last Post: 04-10-2006, 11:24 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts