Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17
  1. #1

    Join Date
    Oct 2012
    Location
    Gold Coast Australia
    Posts
    43

    Power valve fitting

    Hey guys. Easy one for you.
    Mom fitting the new updated oem yamaha powervalves. But before I slide them in. Witch way round do they go. As in the taper part.
    Dose the taper face up as you slide it in or face down when slid in.

    Thanks in advance.


  2. #2
    pokplalya22's Avatar
    Join Date
    Jun 2011
    Location
    NY
    Posts
    485
    +1
    4
    Tapered side down

  3. #3

    Join Date
    Oct 2012
    Location
    Gold Coast Australia
    Posts
    43
    Thanks buddy. I fitted all new power valves but they are still not opening when you ride it. They still do there sweep when engine is killed etc. I've checked the servo and adjusted the cables but still no go. They all move by hand and all 3 have new valves. Can anyone help or guide me what do do next.

  4. #4
    pokplalya22's Avatar
    Join Date
    Jun 2011
    Location
    NY
    Posts
    485
    +1
    4

    Re: Power valve fitting

    Is it confirmed with the covers off that they move? Or you just hear them cycling?

  5. #5

    Join Date
    Oct 2012
    Location
    Gold Coast Australia
    Posts
    43
    No they all move with the covers off. I'm thinking its the servo. Although it cycles. It cycles its self every 30 seconds or so when it's not running so ill change that and go from there.

  6. #6

    Join Date
    Oct 2012
    Location
    Gold Coast Australia
    Posts
    43
    i fitted a mates servo motor tonight. one question for you... with my old servo it dose a sweep every time you connect the battery, and then every 20/30 seconds untill you disconnect the battery.
    with the new one it dose not sweep when the battery is connected,

    so can some tell me or try disconnecting there battery and tell me if the motor sweeps please.
    i cant start the ski as its late at night and next door will not be happy haha
    so i cant test it till the weekend.

    but please if you can tell me what happens when the battery is connected that will help loads

    thanks

  7. #7

    Join Date
    Jun 2010
    Location
    LKN, NC
    Posts
    22
    It sould not sweep when you connect your battery. Sounds like your old one was broke.

  8. #8

    Join Date
    Oct 2012
    Location
    Gold Coast Australia
    Posts
    43
    Hey guys. Just tested my servo on a mates ski and it works 100% on his. But still sweeps ever 20 seconds on mine and the valves do not open. Where next. As I said it only happend when removing the exhaust and stinger then I move the motor and hung it from over the side. That's when it started doing this. Dose the wiring go round by the air box etc. maybe I've trapped a wire by doing the exhaust. How do they no when to open? As I've had the dash wires and all the wires at the front apart etc.
    please help. I'm running out of ideas.
    Maybe some one can give me a run down of what to check from a to b

  9. #9
    You need to pin the wheel on where the pv cable meets the first cylinder. There is a hole there to center the wheel to the cylinder. then make sure your servo powered up and centerd itself. Attach thr cables and make sure they are snug and adjusted correctly with the wheel pinned to the cylinder and PV centered. It may be sensing its a little off and causing the eratic movement. Also check the connection at the plug its even slight dirty they cycle too.

  10. #10

    Join Date
    Oct 2012
    Location
    Gold Coast Australia
    Posts
    43
    Can someone please tell me what voltage the grey wire has please. I've got 2 volts and it drops when I wiggle the wires.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. I love Power Valves
    By eric1238 in forum Yamaha PWC Performance (2-stroke)
    Replies: 11
    Last Post: 05-02-2006, 10:48 AM
  2. REEDS OR POWER VALVES
    By GTNWRECT in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 04-08-2006, 11:04 AM
  3. Keeping power valves intact
    By Fandini in forum Yamaha PWC Performance (2-stroke)
    Replies: 6
    Last Post: 03-31-2006, 08:45 AM
  4. Power Valve Jism
    By GeorgiaMick in forum Yamaha PWC Performance (2-stroke)
    Replies: 6
    Last Post: 01-14-2006, 12:37 AM
  5. power valve bracket ?
    By sponge racing in forum Yamaha PWC Performance (2-stroke)
    Replies: 6
    Last Post: 12-25-2005, 03:35 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •