Results 1 to 5 of 5
  1. #1

    Polaris Virage TXi wont spark

    I have a Polaris Virage TXi that was running fine but now wont spark. It has been put into the workshop for repairs and after running some tests, they determined that it is a wiring issue. It sounds like they are going to take forever to solve the problem, so I wanted to try and fix it myself. Does anyone know which wires could be preventing the spark plugs from sparking? Could they be from certain sensors?

    Thanks


  2. #2
    LaveyT's Avatar
    Join Date
    Jul 2008
    Location
    Cincinnati
    Posts
    672
    +1
    10

  3. #3
    Thanks a lot

    Do you know where I could get a wiring diagram for it from? Everywhere I looked kept directing me to the same website which you have to pay for. Do you know where I could get one for free?

  4. #4
    Myself's Avatar
    Join Date
    May 2007
    Location
    North Central Arkansas
    Posts
    2,771
    +1
    129
    Add an extra ground wire for testing purposes from the battery straight to the electrical box and then check for spark. Also perform the stator tests for your model. If that stuff checks good it's probably the CDI. I checked out 3 different Polaris machines last year with no spark. 2 were bad CDI and 1 was complete fried electrical system.

  5. #5
    LaveyT's Avatar
    Join Date
    Jul 2008
    Location
    Cincinnati
    Posts
    672
    +1
    10
    Quote Originally Posted by gkr View Post
    Thanks a lot

    Do you know where I could get a wiring diagram for it from? Everywhere I looked kept directing me to the same website which you have to pay for. Do you know where I could get one for free?
    if you dig thru the information from that link and ask questions you will get the help that you need. Using the search function you will find tons of posts about diagnosing your ski. K447 has a bunch of experience with that ski.
    Good luck!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2002 Polaris Virage TXi 1200 - Help help help!!! No spark???
    By REV968 in forum Polaris Open Discussion
    Replies: 6
    Last Post: 09-23-2015, 09:19 PM
  2. 2002 polaris virage txi wont break 30 mph and stutters
    By zigp1212 in forum Polaris PWC Performance
    Replies: 6
    Last Post: 04-25-2015, 06:10 PM
  3. 2001 Polaris Virage TXI/ No Spark/Weak Spark
    By Hazmat1234 in forum Polaris Open Discussion
    Replies: 4
    Last Post: 08-29-2012, 12:31 AM
  4. 2001 Polaris Virage TXI Runs Fine Then No Spark
    By mims818 in forum Polaris Open Discussion
    Replies: 5
    Last Post: 09-06-2011, 11:15 AM
  5. 2002 Polaris Virage TXi 1200 - Help help help!!! No spark???
    By REV968 in forum Polaris How To & FAQs
    Replies: 1
    Last Post: 06-18-2011, 11:52 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •