Results 1 to 6 of 6
  1. #1

    Exclamation polaris slx 1050 electrical problem

    hi i just a cheap project ski polaris slx 1050 99 model the guy i bought it off said all it needed was a new stator coil finally got the flywheel off and changed the stator sweet had spark when putting everything back in and putting new battery in think i have shorted something out in cdi box the battery is fully charged but sounds flat the starter wont engage what else shoul i check i went back through checked stator plugs, battery, battery teminals, fuses all seem to be good plz help cheers


  2. #2
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    Check your start solenoid. Also make sure your battery is strong. A weak battery will cause a troubleshooting nightmare on these things. A new battery doent necessarily equate to a strong battery.

  3. #3
    Tony's Avatar
    Join Date
    May 2007
    Location
    North Carolina
    Posts
    1,760
    +1
    38
    Quote Originally Posted by Voigta View Post
    battery is fully charged but sounds flat the starter wont engage
    When you say the battery sounds flat do you mean the starter is spinning but not engaging the flywheel and/or not spinning the motor? If the answer is yes, check the bendix or idler gear (gear assembly located next to flywheel) and the flywheel woodruff key.

  4. #4
    Ok fixed problem was battery terminals not getting enough contact but now got no spark getting 10.6 from battery any ideas?

  5. #5
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,587
    +1
    1,272
    Quote Originally Posted by Voigta View Post
    Ok fixed problem was battery terminals not getting enough contact but now got no spark getting 10.6 from battery any ideas?
    You need MORE than 10.6 volts to fire the CDI ignition.

    Also;
    Lanyard in place?
    Updated or original ignition system?
    Stop switch wire ungrounded?
    All electrical box wires connected properly?
    Hold bilge button down while cranking. Do you have spark?

    See my signature links for more info on the electrical system

  6. #6
    Quote Originally Posted by Voigta View Post
    hi i just a cheap project ski polaris slx 1050 99 model the guy i bought it off said all it needed was a new stator coil finally got the flywheel off and changed the stator sweet had spark when putting everything back in and putting new battery in think i have shorted something out in cdi box the battery is fully charged but sounds flat the starter wont engage what else shoul i check i went back through checked stator plugs, battery, battery teminals, fuses all seem to be good plz help cheers
    Need to add I didn't change stator my buddy did he now thinks he seen spark prob not because I've a new thread with a major prob

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. New here, 1999 Polaris SLX 1050 problem
    By Chattanoogajack in forum Polaris Open Discussion
    Replies: 1
    Last Post: 10-10-2016, 10:51 AM
  2. 1999 Polaris SLX 1050 running problems
    By hunter2003k in forum Polaris Tech Tips and Info
    Replies: 6
    Last Post: 10-12-2012, 08:32 AM
  3. WTB 1999 polaris slx 1050 cdi box
    By h2jim in forum Polaris Classifieds
    Replies: 5
    Last Post: 03-28-2012, 07:16 AM
  4. 99 Polaris SLX 1050 problem
    By clay1191 in forum Polaris Open Discussion
    Replies: 12
    Last Post: 01-25-2012, 09:11 PM
  5. 2002 Polaris Virage I Electrical Problem
    By gusie1 in forum Polaris Open Discussion
    Replies: 10
    Last Post: 09-30-2007, 07:16 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •