Results 1 to 7 of 7
  1. #1

    Polaris 1997 sl 780 MFD Problem

    Hello Guys i need help my mfd is not working properly not all the digits can be seen or can be seen at an angle this is what it looks like when i stoped using it, it was working fine now it just look like that.

    Thank you
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	$(KGrHqZ,!rgFBGhULrO7BQZvsDnn4g~~60_35.JPG 
Views:	142 
Size:	16.7 KB 
ID:	288942  
    Last edited by K447; 12-21-2012 at 01:28 PM.


  2. #2
    Sooo...how much for the 780? stimpsonjcat's Avatar
    Join Date
    Apr 2012
    Location
    Georgia - Lake Lanier - near 6TH
    Posts
    853
    +1
    19
    Sometimes this is just the connections from the mainboard to the LCD.

    I have had two with this behavior and just cleaning the contacts and LCD edge solved the problem.

    Yes, that means taking it apart.

  3. #3
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,574
    +1
    1,272
    See the MFD section from my signature links.

    There is a repair process, but you must be careful opening up the case.

  4. #4
    thank you worked like a charm

  5. #5
    It went bad again it worked after i did that process but same thing happened after a day whats the problem i took it apart several times now its getting frustrating i also chaned the quarer amp fuse....

  6. #6
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    Did you clean the contacts and everything? I use denatured alcohol on a cotton swab. Make sure the screws holding the board down are tight, but be careful not to overtighten them.

  7. #7
    Sooo...how much for the 780? stimpsonjcat's Avatar
    Join Date
    Apr 2012
    Location
    Georgia - Lake Lanier - near 6TH
    Posts
    853
    +1
    19
    Alignment/clamping could be off. With it powered up and misbehaving, does pressure in any particular spot help/hurt. Might lead you to a solution.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Polaris SL 780 Fuel problem
    By Bigdog1597 in forum Polaris PWC Performance
    Replies: 1
    Last Post: 06-27-2016, 01:23 PM
  2. Polaris sl 780 carb problem
    By Yamaha-Fx17 in forum Polaris How To & FAQs
    Replies: 1
    Last Post: 06-25-2013, 08:40 AM
  3. 1997 polaris sl 780 Accelaration Problem
    By Yamaha-Fx17 in forum Polaris How To & FAQs
    Replies: 7
    Last Post: 06-05-2013, 02:35 PM
  4. Polaris 1997 sl 780 Trim Not Working
    By Yamaha-Fx17 in forum Polaris How To & FAQs
    Replies: 2
    Last Post: 12-21-2012, 07:32 PM
  5. 1997 Sl 780
    By ZiGz in forum Polaris PWC Performance
    Replies: 7
    Last Post: 05-08-2007, 10:46 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •