Results 1 to 3 of 3
  1. #1

    Polaris 1997 sl 780 Trim Not Working

    Hey guys,
    My trim isn't woking what should i look out for when i press the switch up / down nothing works Thank you.

    - opened electrical box changed the connections to new ones nothing happend still .

  2. #2
    Banned User
    Join Date
    Jun 2010
    Milwaukee WI
    Trim only works with the engine running. If you have a bilge button you can hold that down and then try operating the trim.

  3. #3
    thank you that gave me an idea i opened the electical box switched the bildge pump wires with the trim wires and the trim works perfectly just wanted to know if it was siezed or anything Thank you very much sir.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Pro cdi and 780 will not work on 94 650..
    By Rodneyae in forum Polaris Open Discussion
    Replies: 25
    Last Post: 05-16-2007, 07:48 PM
  2. mfd and trim not working
    By allpolaris in forum Polaris How To & FAQs
    Replies: 1
    Last Post: 03-27-2007, 08:28 PM
  3. Trim not working?
    By YJSONLY in forum Sea Doo Open Discussion
    Replies: 11
    Last Post: 02-10-2007, 02:07 PM
  4. 2005 RXP Trim not working?
    By idizzy in forum 4-Tec Performance
    Replies: 10
    Last Post: 06-27-2006, 05:41 PM
  5. Trim not working after winter
    By SpeedStang95 in forum Sea Doo Open Discussion
    Replies: 10
    Last Post: 05-02-2006, 08:24 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts