Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15
  1. #1

    Sho clutch / boost issue

    hey guys ive had this issue twice and wanted to know if anyone experienced anything simular.when i first put the ski in the water after letting it warm idle for a while it wont hit boost when i initially go wide open rpms will climb to 6000ish and top mph around 60ish first couple of times i get on it and when i ease off the throttle no release from the blow off valve.its happened twice always when i first put the ski in the water and ive pulled over and everything goes right back to normal all day rpms at 7700ish and mph 72ish and a strong release from the blow off valve.its only happened twice both when the ski is first put in the water and ive ridden dozens of times between the two occasions without a hiccup.ive had a clutch failure before and it feels simular but ofcourse its random with boost never cutting back in after a few hits.i dont remember the clutch failure having any prior symptoms either.do these skis have any sort of safety features that limits the engine until its very warm ? any input would be appreciated.thanks in advance guys.


  2. #2
    Whats that whistling noise? jtskier11's Avatar
    Join Date
    Sep 2007
    Location
    Right side of Kansas
    Posts
    4,342
    +1
    87
    Mine acted like that right before my sprag overcammed, locked and I had to replace the clutch. But my rpm's wouldnt climb past 5k, had no power and no more gear noise from the SC.

  3. #3
    SurfRider's Avatar
    Join Date
    Jun 2010
    Location
    NJ
    Posts
    735
    +1
    13

    Sho clutch / boost issue

    What oil are you using?

  4. #4
    wouldnt know skis got 50hrs and all services so far have been at the stealership.

  5. #5
    Carbonic's Avatar
    Join Date
    Sep 2011
    Location
    Omaha, Nebraska
    Posts
    448
    +1
    32
    I'd assume Yamalube then..

  6. #6
    Kristian Keppel Waterholics's Avatar
    Join Date
    Apr 2010
    Location
    Trinidad & Tobago
    Posts
    1,405
    +1
    38
    Quote Originally Posted by SurfRider View Post
    What oil are you using?
    What oil is best to use ?

  7. #7
    is there a video or any information online on how the stock supercharger clutch engages ? this little issue has me stumped

  8. #8
    SurfRider's Avatar
    Join Date
    Jun 2010
    Location
    NJ
    Posts
    735
    +1
    13

    Sho clutch / boost issue

    The reason I was asking is if you accidentally put an oil in with "friction modifiers" (which most regular oils do) that causes the clutch to slip like that.

  9. #9
    SurfRider's Avatar
    Join Date
    Jun 2010
    Location
    NJ
    Posts
    735
    +1
    13

    Sho clutch / boost issue

    Quote Originally Posted by Waterholics View Post
    Quote Originally Posted by SurfRider View Post
    What oil are you using?
    What oil is best to use ?
    I don't know that any oil is necessarily better than others, but it cannot have "friction modifiers" if using with a SC clutch. I use BelRay EXS 10w-50, but that is just my preference. I'm sure that something like Amsoil is also very good. I would say put the best oil that you can afford. The skis only take 3 to 3.5 quarts of oil, so it's not too bad cost wise (unlike my 911 that takes 11 quarts).

  10. #10
    800AMSOIL4U's Avatar
    Join Date
    Aug 2006
    Location
    Morgan Hill, CA
    Posts
    5,024
    +1
    132
    You can use the AMSOIL Synthetic 10w-40 Marine Oil. Here is Jerry's link here from The Green Hulk.
    https://www.amsoil.com/storefront/wcf.aspx?zo=1499968

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. SHO original boost pressure
    By Bruno_Shiftech in forum Yamaha PWC Performance (4-stroke)
    Replies: 22
    Last Post: 04-24-2010, 07:56 PM
  2. Sho Handling/safety Issue
    By Rip'nTear SHO in forum High Performance Watercraft Safety
    Replies: 5
    Last Post: 10-12-2008, 01:10 PM
  3. Sho Handling/safety Issue
    By Rip'nTear SHO in forum Yamaha PWC Performance (4-stroke)
    Replies: 48
    Last Post: 10-05-2008, 12:36 AM
  4. Sho Rev Limit Issues
    By anarchy101 in forum Yamaha PWC Performance (4-stroke)
    Replies: 5
    Last Post: 09-06-2008, 10:40 AM
  5. 2007 speedster 150 155hp clutch washer issues?
    By sugarman in forum Sea Doo Sport Boats
    Replies: 1
    Last Post: 06-27-2007, 11:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •