Results 1 to 10 of 10

Thread: Steaming pisser

  1. #1

    Steaming pisser

    Ok, so i took my 98 xpl out today. Run great at low revs. But as soon as i started riding a bit harder the exhaust seems to have heated up and instead of water coming out the pisser instaed steam was coming out. The engine overheat alarm did NOT come on. Runs fine on the garden hose. Im really confused on what it could be.


  2. #2
    Tiny's Avatar
    Join Date
    Sep 2006
    Location
    The Atl
    Posts
    3,561
    +1
    578
    When on the garden hose it flushes backwards so it wont over heat in most cases....You need to remove all your cooling lines to the pipe and head and blow thru them with compressed air..You have a blockage somewhere

  3. #3
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    Quote Originally Posted by Tiny View Post
    When on the garden hose it flushes backwards so it wont over heat in most cases....You need to remove all your cooling lines to the pipe and head and blow thru them with compressed air..You have a blockage somewhere
    +1..

  4. #4
    Cool. will have a look.

  5. #5
    Steve STSPERFORMANCE's Avatar
    Join Date
    Dec 2007
    Location
    Cambridge, Ohio
    Posts
    2,701
    +1
    116
    Antibiotics help too...

  6. +1 by:


  7. #6
    I actually found that when i got the pump rebulilt the mechanics didnt put a grommet between the pump housing and the hull. So ,most of the pressurized water was escaping b4 it entered the main hose.

  8. #7
    Tiny's Avatar
    Join Date
    Sep 2006
    Location
    The Atl
    Posts
    3,561
    +1
    578
    That will do it

  9. #8

    Join Date
    Dec 2012
    Location
    Puerto rico
    Posts
    17
    Quote Originally Posted by chooka View Post
    ok, so i took my 98 xpl out today. Run great at low revs. But as soon as i started riding a bit harder the exhaust seems to have heated up and instead of water coming out the pisser instaed steam was coming out. The engine overheat alarm did not come on. Runs fine on the garden hose. Im really confused on what it could be.
    it hapened to me a while ago and it was a burnt cylinder head gasket.some of the copression was leaking from the fire ring to the water jacket, and found it's way to the pisser outlet.

  10. #9
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    Sounds like you need to stop hanging out with the girls on the street...
    LoL...

  11. #10
    Mine only seems to do it once its hot tho.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Kawasaki 15f blowing steam out of pisser .. oops÷
    By macGruber in forum Kawasaki How To & FAQs
    Replies: 4
    Last Post: 07-12-2016, 01:16 PM
  2. Kawasaki 15f blowing steam out of pisser .. oops÷
    By macGruber in forum Kawasaki PWC Performance (4-stroke)
    Replies: 4
    Last Post: 07-12-2016, 01:16 PM
  3. 1300r, steam out of the pissers
    By swamped in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 06-26-2010, 05:55 AM
  4. Cosmetic Pisser Accessory.
    By ccassone in forum 2-Stroke Performance
    Replies: 4
    Last Post: 02-22-2006, 10:42 PM
  5. Watercraft Pisser
    By ramnj in forum Sea Doo Open Discussion
    Replies: 7
    Last Post: 10-06-2005, 12:12 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •