Results 1 to 4 of 4
  1. #1
    brendanm's Avatar
    Join Date
    Jan 2013
    Location
    Gold Coast, Australia
    Posts
    738
    +1
    149

    Electrical problem with 03 gtx sc

    Hey guys, been lurking for a while now but this is my first post. Just got an 03 gtx sc, 140hrs, goes like a champ except I have error codes p0600 and p1607. Speed and fuel gauge will randomly cut out and will beep. Strange thing is if it does it, I can up the revs a little and the dash will work properly again. Not sure if its related but the top 15 amp main fuse was distorted and looks like it has been making poor contact.

    Thanks in advance!


  2. #2
    Clean all contacts and also unplug your handlebar and gauge harnesses to clean the contacts. My guess it is something minor like a dirty or loose connection.

  3. #3
    brendanm's Avatar
    Join Date
    Jan 2013
    Location
    Gold Coast, Australia
    Posts
    738
    +1
    149
    Thanks for the reply, I cleaned up the fuse and holder and no longer get the codes but now get one for the instrument cluster. I think its as you say, bad connections, I will replace the fuse holder and clean and dialectric grease all the connectors as soon as I get a chance. I'll update this thread when I've done it.

  4. #4
    brendanm's Avatar
    Join Date
    Jan 2013
    Location
    Gold Coast, Australia
    Posts
    738
    +1
    149
    Forgot about this thread, figured Id better update it. Replaced the 30 amp fuse contacts and holder, no more codes so all is good. Still have gauges randomly cutting out, have disconnected and reconnected everything, might try replacing the gauges at some stage but it is far better now anyway. Thanks

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 03 gtx sc rpm - speed - problems
    By 5Bulldogs in forum 4-Tec Performance
    Replies: 12
    Last Post: 07-26-2008, 03:14 PM
  2. 03 GTX SC with Solas 12/20, what RPM's?
    By gbest in forum Sea Doo Open Discussion
    Replies: 7
    Last Post: 07-21-2008, 11:32 PM
  3. Help with 03 gtx sc
    By JOJO567 in forum 4-Tec Performance
    Replies: 2
    Last Post: 07-12-2007, 12:14 PM
  4. 03 GTX SC problem
    By joelykool in forum 4-Tec Performance
    Replies: 13
    Last Post: 05-15-2007, 10:48 PM
  5. Problem with 03 SC 4-Tec....
    By LiquidDI in forum 4-Tec Performance
    Replies: 1
    Last Post: 06-25-2006, 07:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •