Results 1 to 6 of 6
  1. #1

    HELP - 1996 Polaris SLT 750

    1996 Polaris SLT 750

    Hello Group,
    Just joined and need your feedback re: 1996 Polaris SLT 750. Am looking at purchasing/repairing this PWC and only have this bit of info. to share. The PWC only has 29 hrs. on it. In 1997 @ 25 hrs. it started running rough so it was taken to shop under warranty. They repaired one cyl. and piston which had a hole on the top of it. It was taken out to the lake the following month and ran but the RPMs just weren't there again. It was taken to another shop during that trip which also was a dealer and they refused to work on it. That is all the info. I have on it and it has been sitting ever since. Apparently there is no paperwork to verify all the above info. Battery gone and fuel needs to be drained for starters. Would appreciate your feedback. Thanks, Mark


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,601
    +1
    1,276
    Start by looking through my signature links.

    Pay attention to the recommended maintenance and fuel system plus carb rebuild info.

  3. #3
    john zigler's Avatar
    Join Date
    Aug 2006
    Location
    WI
    Posts
    2,545
    +1
    33
    a holed piston is typically from a lean condition, ( detonation).

    the fujis are known for this. i would bet who ever repaired the ski did not address the original issue that caused the 1st failure.

    we have all the needed fuel upgrades here in stock.

  4. #4
    BlueFishCrisis's Avatar
    Join Date
    Aug 2011
    Location
    Medina, Ohio, United States
    Posts
    4,988
    +1
    140
    Quote Originally Posted by Jive55 View Post
    1996 Polaris SLT 750

    Hello Group,
    Just joined and need your feedback re: 1996 Polaris SLT 750. Am looking at purchasing/repairing this PWC and only have this bit of info. to share. The PWC only has 29 hrs. on it. In 1997 @ 25 hrs. it started running rough so it was taken to shop under warranty. They repaired one cyl. and piston which had a hole on the top of it. It was taken out to the lake the following month and ran but the RPMs just weren't there again. It was taken to another shop during that trip which also was a dealer and they refused to work on it. That is all the info. I have on it and it has been sitting ever since. Apparently there is no paperwork to verify all the above info. Battery gone and fuel needs to be drained for starters. Would appreciate your feedback. Thanks, Mark
    Welcome - K447's links are very worthwhile and are considered a must for getting to know your ski. Need to find out exactly what year you have by looking at the vin plate. The last two digits of the vin is your model year. Polaris stopped making the 750 in 95, so you may have something either older, or a different motor......

    Please post lots of pics and ask lots of question!!!

  5. #5
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    They only made a SLT 750 in 94 and 95. The 94 had a white bottom, the 95 had a teal bottom.

  6. #6
    caliburn's Avatar
    Join Date
    Aug 2012
    Location
    Sister lakes Mich
    Posts
    531
    +1
    12
    Right to all of the above, upgrade from that single feed fuel pump, there junk and motor killers, Is it locked up?, Hours on those MFD's dont mean much, I have handled alot of them and they tend to reset from time to time, If it was me I would plan on pulling the motor to go through the whole thing, you dont know the condition of the crank bearings and you will never know if one will go south untill its to late, there are alot of other things that you will need to know to do after you have done all of the above.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Hi Folks, Need s a little help on Polaris slt 750 electrical issue
    By Mattwnh in forum Polaris Tech Tips and Info
    Replies: 3
    Last Post: 07-16-2013, 08:20 PM
  2. help/1996 Polaris SLT 700 - no spark, broken Tan wire
    By bartman in forum Polaris Open Discussion
    Replies: 7
    Last Post: 07-10-2011, 03:54 PM
  3. Please help 1996 polaris slt
    By KHVETTE in forum Polaris How To & FAQs
    Replies: 0
    Last Post: 05-21-2010, 11:22 AM
  4. Need Help! 1996 Polaris Slt 780 Mfd!
    By wjstewart in forum Polaris How To & FAQs
    Replies: 15
    Last Post: 08-13-2008, 10:44 PM
  5. Newbie needs help! 1996 Polaris SLT
    By cfish2169 in forum Polaris Open Discussion
    Replies: 6
    Last Post: 04-18-2007, 09:46 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •