Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 24
  1. #1
    SLASHER's Avatar
    Join Date
    Jun 2007
    Location
    Australia, Perth WA
    Posts
    3,263
    +1
    474

    New intake rocker arm broke

    Has any one had a rocker arm (intake) break before ?

    I did 1.5hrs on my and snapped clean off ... Lucky no other damage ...


  2. #2
    shrabber's Avatar
    Join Date
    Apr 2008
    Location
    Jacksonville, FL
    Posts
    5,305
    +1
    376
    What springs you running?

  3. #3
    SLASHER's Avatar
    Join Date
    Jun 2007
    Location
    Australia, Perth WA
    Posts
    3,263
    +1
    474
    Running Riva springs and Ferrea valves .... All new ...

  4. #4
    Fast & Loud meeper's Avatar
    Join Date
    Jul 2005
    Location
    West Grove, PA
    Posts
    5,019
    +1
    54
    install error

  5. +1 by:


  6. #5
    SLASHER's Avatar
    Join Date
    Jun 2007
    Location
    Australia, Perth WA
    Posts
    3,263
    +1
    474
    Added new rocker and trying again ...

    Only thing I can think is that it may be a faulty part or the valve install height is wrong ...

    The head shop assured that they where all the same and right ...also head is new so seats only cut once for new valves ...

    Just wanted to see if there was a shitty batch of rockers ???

  7. #6
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407
    Happened to a friend on his last ride.

  8. #7
    shrabber's Avatar
    Join Date
    Apr 2008
    Location
    Jacksonville, FL
    Posts
    5,305
    +1
    376
    Quote Originally Posted by meeper View Post
    install error
    smart ass lol

  9. #8
    SLASHER's Avatar
    Join Date
    Jun 2007
    Location
    Australia, Perth WA
    Posts
    3,263
    +1
    474
    Quote Originally Posted by beerdart View Post
    Happened to a friend on his last ride.
    Why did it break ? Was it a faulty part or install height?

  10. #9
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407
    Not sure never got the full diagnosis.
    Quote Originally Posted by SLASHER View Post
    Quote Originally Posted by beerdart View Post
    Happened to a friend on his last ride.
    Why did it break ? Was it a faulty part or install height?

  11. #10
    Fast & Loud meeper's Avatar
    Join Date
    Jul 2005
    Location
    West Grove, PA
    Posts
    5,019
    +1
    54
    if the rocker wasnt seated properly on the valve tip that would cause it

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. New Billet Rocker Arms from Rotax Racing
    By Green Hulk in forum 4-Tec Performance
    Replies: 51
    Last Post: 12-21-2013, 03:26 AM
  2. WTB Intake Rocker Arm
    By icdoo in forum Sea Doo Classifieds
    Replies: 5
    Last Post: 04-20-2013, 08:34 AM
  3. Rocker Arm Broke!!!!!!!!!!!!!!Please Help!!!!!!!!!!!!!!!
    By mikeGermany in forum 4-Tec Performance
    Replies: 4
    Last Post: 07-22-2012, 10:12 AM
  4. WTB I need a single (1) Intake Rocker arm
    By wreckingball in forum Sea Doo Classifieds
    Replies: 3
    Last Post: 09-17-2010, 08:06 PM
  5. Intake Rocker Arms? Anyone?
    By WannabeGoing80 in forum 4-Tec Performance
    Replies: 0
    Last Post: 05-05-2007, 08:27 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •