Results 1 to 9 of 9

Thread: wanted cluster

  1. #1

    wanted cluster

    Hello friends have cluster for 2007? i bay . Thanks


  2. #2
    I have a 2009. I think they are the same

  3. #3
    Codeman666's Avatar
    Join Date
    Aug 2007
    Location
    sunny south florida
    Posts
    179
    +1
    8
    Quote Originally Posted by STEVE PWC View Post
    I have a 2009. I think they are the same
    The 09 version will work with an 07 ecu but must be reflashed with the MY2007 firmware to correctly calibrate values

  4. #4

    Join Date
    Sep 2012
    Location
    broken arrow ok
    Posts
    779
    +1
    39
    i have a 2006 if that will work ?

  5. #5
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407
    06 will not work. In 08 all non iControl clusters are flashable with BUds for any year 2006+
    Quote Originally Posted by Turboted View Post
    i have a 2006 if that will work ?

  6. #6
    You can marry my 2009 dash to 2007. You just have to flash it, buds system or the sbt 102 works too

  7. #7
    SLASHER's Avatar
    Join Date
    Jun 2007
    Location
    Australia, Perth WA
    Posts
    3,263
    +1
    474
    How much are they ...

  8. #8
    Quote Originally Posted by Codeman666 View Post
    Quote Originally Posted by STEVE PWC View Post
    I have a 2009. I think they are the same
    The 09 version will work with an 07 ecu but must be re flashed with the MY2007 firmware to correctly calibrate values
    not locking to jack the topic but i recently purchased a cluster got it programed from a 3rd party not buds and it is nutz, it goes from 0rpm to 5,000rpm and then nothing while i give it throttle, and the compass is nuts since it normaly say n,s,w,e i get things like t123 n564 crazy things how can i fix this with out buds.

  9. #9
    Quote Originally Posted by DR2006RXP View Post
    Quote Originally Posted by Codeman666 View Post
    Quote Originally Posted by STEVE PWC View Post
    I have a 2009. I think they are the same
    The 09 version will work with an 07 ecu but must be re flashed with the MY2007 firmware to correctly calibrate values
    not locking to jack the topic but i recently purchased a cluster got it programed from a 3rd party not buds and it is nutz, it goes from 0rpm to 5,000rpm and then nothing while i give it throttle, and the compass is nuts since it normaly say n,s,w,e i get things like t123 n564 crazy things how can i fix this with out buds.
    you go to dealer Seadoo and with B.U.D.S. is possible resolution your problem.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. WTB WANTED - 06+ Gauge Cluster RXP / RXT / GTX
    By Shibby1485 in forum Sea Doo Classifieds
    Replies: 11
    Last Post: 07-27-2012, 07:48 AM
  2. Wanted cluster 2006 up!!
    By tocullo in forum Sea Doo Classifieds
    Replies: 10
    Last Post: 07-16-2012, 09:03 PM
  3. Wanted cluster 2006 up!!
    By tocullo in forum 4-Tec Performance
    Replies: 0
    Last Post: 06-29-2012, 01:13 PM
  4. Wanted: GTX Gauges \ Dash Cluster !!!
    By xBigDaddyx117 in forum Sea Doo Classifieds
    Replies: 7
    Last Post: 06-01-2012, 06:59 AM
  5. Waveraider 1100 Gauge cluster wanted
    By HallPass in forum Yamaha Classifieds
    Replies: 3
    Last Post: 04-26-2009, 05:42 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •