Results 1 to 9 of 9
  1. #1

    Join Date
    Sep 2011
    Location
    Boca Raton, FL
    Posts
    22

    Code 25 with New Knock sensor What Now

    I had the sensor replaced and I'm still getting code after about 30 mins of riding. It runs perfect then I get code and no matter what I do it keeps coming back on. I let the ski sit until next weekend and runs fine for 30-45 mins then same thing. Do you guys think its time for a new ecu or maybe another problem


  2. #2
    AWA MEMBER
    Join Date
    Jan 2008
    Location
    Currituck, North Carolina, United States
    Posts
    4,616
    +1
    247
    Its probably time for a ECU.......the heat gets to them from inside the hull......the Honda has plenty of air coming in but the heat builds up from the turbo, and the engine and keeps the hull temps hot over time takes its toll on the ecu.....its potted so un repairable. I had fab a exhaust fan from a boat bilge fan and helped keep my stuff cool


    I would inspect the engine wire harness to make sure there is no "rubbing" or chafing but otherwise looking at a ECU

  3. #3
    Hey... I too am in process of fixing error code 25 "knock sensor".
    All the typical symptoms... works well at low speed, and then the limit mode after some high speed operation.
    Note the Ski always starts first time... even after sitting around all winter.
    That said, this weekend I pulled the ECM to get the part number so I could assure correct replacement to fix the code 25 problem.
    Note I was careful not to pull on any wires...
    Just to make sure "all was well", I reconnected the ECM and would not start at all.
    When I insert the lanyard, all is well and cranks and cranks... but not even a hint of running.
    Do I need to reprogram something in that I pulled the ECM out of the harness?

  4. #4
    AWA MEMBER
    Join Date
    Jan 2008
    Location
    Currituck, North Carolina, United States
    Posts
    4,616
    +1
    247
    Should not need to reprogram anything.........your ECU must be bad

  5. #5
    xdrian's Avatar
    Join Date
    Nov 2008
    Location
    Brisbane Australia
    Posts
    896
    +1
    225
    ECU has only two conectors check again replug them.
    them check your fuses may have blown one put it back in good luck

  6. #6
    glockm22's Avatar
    Join Date
    Jul 2009
    Location
    Iowa
    Posts
    28
    +1
    2
    Check wiring harness also, I have had 2 in the shop where wires had rubbed threw.

  7. #7
    schredder schredder's Avatar
    Join Date
    May 2010
    Location
    Neptune Beach FL
    Posts
    159
    +1
    1
    Ive seen and dealt with this gremlin many times. Swap your ecu first and see what happens. If its still throwing the code, then in all likelihood, its your harness.
    seems to be common with many of the things Ive worked to diagnose. Your posts don't say what you own, and that would really help. Are you ridding fresh or
    salt water, maybe both? R you the original owner? how many hours are on it? a little history on the ski goes a long way in getting to the bottom of the problem.

  8. #8
    same issues, was harness

  9. #9
    supermac's Avatar
    Join Date
    Dec 2005
    Location
    Mooresville, NC
    Posts
    406
    +1
    10
    Quote Originally Posted by JETSKI JUNKIES View Post
    same issues, was harness
    You can try deoxit D5 spray on all connector terminals. It can work magic.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Vtech with 04 knock sensor? Surprise in my hull?
    By rmk82nd in forum 4-Tec Performance
    Replies: 4
    Last Post: 04-23-2015, 07:13 PM
  2. Replies: 3
    Last Post: 06-10-2014, 12:37 AM
  3. code after installing the knock sensor pigtail
    By kbolaloco1 in forum 4-Tec Performance
    Replies: 3
    Last Post: 07-15-2013, 03:02 PM
  4. code 25 = knock sensor = long ride home
    By dcg9381 in forum Honda Open Discussion
    Replies: 7
    Last Post: 04-07-2012, 01:20 PM
  5. WTB- New Knock Sensor
    By Pwgsx in forum Sea Doo Classifieds
    Replies: 6
    Last Post: 06-28-2009, 08:45 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •