Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 29
  1. #1
    Impulses's Avatar
    Join Date
    Dec 2011
    Location
    europe
    Posts
    822
    +1
    27

    intercooler leak?

    is this a leak from my OEM intercooler?
    Model: RXT X 260 RS 2011 with 63 hours

    Click image for larger version. 

Name:	FUGA III.jpg 
Views:	159 
Size:	51.5 KB 
ID:	290153Click image for larger version. 

Name:	FUGA.jpg 
Views:	177 
Size:	53.7 KB 
ID:	290154


  2. #2
    SLASHER's Avatar
    Join Date
    Jun 2007
    Location
    Australia, Perth WA
    Posts
    3,263
    +1
    474
    Remove and bung one end fit garden hose and slowly open tap and will soon if its leaking ...

    The 2011 ic are just crap so yes it most likely to be leaking ..

  3. #3
    Impulses's Avatar
    Join Date
    Dec 2011
    Location
    europe
    Posts
    822
    +1
    27
    then you think is the IC?
    could not be the engine heat exchanger?
    The IC (intercooler) of sea doo 2013 is still good or problematic?

    thanks

  4. #4
    shrabber's Avatar
    Join Date
    Apr 2008
    Location
    Jacksonville, FL
    Posts
    5,305
    +1
    376
    Milky looks like its dripping on it more than leaking from it..Intercooler's leak internally for the most part hence "inner". How does it run? From Looking at That pic that intercooler will mean its leaking internally and externally for it to look like that. Heres a pic of a very very bad internal blow out but dry as a whistle on the outside... Get My drift

    If I had to guess The substance is some lubricant that formulated there from fogging or general Maintaince
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	IMG_0416.jpg 
Views:	232 
Size:	56.2 KB 
ID:	290161  
    Last edited by shrabber; 01-14-2013 at 10:46 AM.

  5. #5
    Impulses's Avatar
    Join Date
    Dec 2011
    Location
    europe
    Posts
    822
    +1
    27
    seems like a mixture of motor oil and water ...
    comes under the intercooler underneath
    also there is a very obvious loss of rpm despite having three hours with Riva stage I kit.
    Watch the video:

  6. #6
    Impulses's Avatar
    Join Date
    Dec 2011
    Location
    europe
    Posts
    822
    +1
    27
    we see that the maximum RPM is maintained 7,700 .... :-K

  7. #7
    Impulses's Avatar
    Join Date
    Dec 2011
    Location
    europe
    Posts
    822
    +1
    27
    no one else can help me? and confirm if I have a leak in the intercooler.
    The Riva Kit stage I only run 7700 rpm max, do not you think?

  8. #8
    83.0 @ 8400 jhill19's Avatar
    Join Date
    Jul 2010
    Location
    Teays Valley, West Virginia
    Posts
    2,800
    +1
    81

    intercooler leak?

    Pressure test the ic. Also check sc slip. Check oil level and spark plugs

  9. #9
    stuckmoto's Avatar
    Join Date
    Jun 2010
    Location
    Newark, De
    Posts
    1,485
    +1
    59
    Quote Originally Posted by jhill19 View Post
    Pressure test the ic. Also check sc slip. Check oil level and spark plugs
    +1
    If you're leaking oily mix like that you probably have a serious SC seal leak. How does the SC/IC hose look? Same goes for the IC/TB hose.
    Test the IC. Are you running a catch can with upgrade? Or dumping back into intake?
    I agree it looks like external lube + water (from maybe you're hatches leaking).
    The 7700 rpm is def an issue. Did you have that issue before the Stage 1 upgrade, soon after, or just recently?

  10. #10
    Impulses's Avatar
    Join Date
    Dec 2011
    Location
    europe
    Posts
    822
    +1
    27
    The problem arose three hours after installing the Riva kit
    sorry but...That is the SC?
    Hoses are good, I have not seen any leaks ...
    bufff the bike is under warranty and my dealer does not know what to do, I say that connected the PC to see if pwc gives some error ....
    I'm really worried
    in the video you can see that the you can see that the maximum RPM are 7,700 in the second 0:45

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Missing 500 rpm + rusty spark plugs = stock intercooler leak
    By Dan_FZR in forum Yamaha PWC Performance (4-stroke)
    Replies: 6
    Last Post: 03-21-2011, 05:27 PM
  2. WTB aftermarket intercooler riva intercooler leaking
    By ctct2118 in forum Sea Doo Classifieds
    Replies: 1
    Last Post: 12-07-2010, 08:26 AM
  3. how do you know an intercooler leaks?
    By otoss in forum 4-Tec Performance
    Replies: 5
    Last Post: 09-27-2010, 09:17 PM
  4. Intercooler leak alarm??
    By alex_baker202 in forum 4-Tec Performance
    Replies: 7
    Last Post: 08-03-2010, 10:58 PM
  5. X Intercooler leaking
    By Antiguan FZR in forum 4-Tec Performance
    Replies: 6
    Last Post: 11-04-2008, 02:28 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •