Page 1 of 2 1 2 LastLast
Results 1 to 10 of 19
  1. #1
    Tas_RXP's Avatar
    Join Date
    May 2005
    Location
    Melbourne Australia
    Posts
    44

    Seadoo RXTX 260 Low Oil Pressure

    Hi Guys,
    Just need some information. I have recently installed ET127 Drop In Wheel (thanks Jerry) with the 3mm spacer into my 2010 RXTX 260. Also running a Re Mapped ECU 8600 and 4 inch Air Intake,stock prop and titanium valve guides.
    Managed to squeeze 8640RPM's at 76.25MPH. Issue is a Low Oil Pressure warning comes up on the screen at those RPM's and it also happens at 8400 - 8500 rpm when i completely back of the throttle. Prior to installed the ET127 i had never experienced the Low Oil Pressure even with the Re Mapped ECU.
    I assume this is happening due to the excessive RPM's. I am looking at installing a Skat Trak 14-19 to drop the RPM's and hopefully gain some top end.
    Just wondering am i on the right track.


  2. #2
    shrabber's Avatar
    Join Date
    Apr 2008
    Location
    Jacksonville, FL
    Posts
    5,305
    +1
    376
    Go Back to Basics... Check Oil Level warm, what type Of oil you are running, how recent your oil has been changed, verify oil pressure. Of course check all your connections!!!

  3. #3
    Water4fire's Avatar
    Join Date
    May 2005
    Location
    New Braunfels TX.
    Posts
    10,073
    +1
    791
    Whats the oil level? Mine do this when I run the oil to close to the bottom of the dipstick.

  4. #4
    Tas_RXP's Avatar
    Join Date
    May 2005
    Location
    Melbourne Australia
    Posts
    44
    Shrabber oil levels were checked when warm and oil was only 5hrs old. Only using genuine Seadoo XPS Oil. I recently had to change the intercooler due to it leaking. Oil wasn't milky but pretty sure some water would of gone through the throttle body. Now you've got me thinking. Could this be the issue ?

  5. #5
    Tas_RXP's Avatar
    Join Date
    May 2005
    Location
    Melbourne Australia
    Posts
    44
    Oil level was normal. Centre of the dip stick.

  6. #6
    shrabber's Avatar
    Join Date
    Apr 2008
    Location
    Jacksonville, FL
    Posts
    5,305
    +1
    376
    Change oil again. If you only cycled oil once since leaking intercooler change it again your viscosity could breaking down. Same thing applies with some of the cheaper Oil's out there when engine warms up and higer rpm's oil pressure dont follow to Par. Change oil and Filter You Will Be Happy!! May Have a oil switch wacking Out but Lets go with Fresh Oil Change and Filter Safe and Effective

  7. #7
    Tas_RXP's Avatar
    Join Date
    May 2005
    Location
    Melbourne Australia
    Posts
    44
    Quote Originally Posted by shrabber View Post
    Change oil again. If you only cycled oil once since leaking intercooler change it again your viscosity is breaking down. Same thing applies with some of the cheaper Oil's out there when engine warms up and higer rpm's oil pressure dont follow to Par. Change oil and Filter You Will Be Happy!!
    Thanks for the advice will definately give it a go.

  8. #8
    Water4fire's Avatar
    Join Date
    May 2005
    Location
    New Braunfels TX.
    Posts
    10,073
    +1
    791
    Yep and it can mess up the oil pressure sensor under the manifold. So you may need a new sensor. I have had to change a few after carbon seal failures and the ski gets water in the oil.

  9. #9
    Tas_RXP's Avatar
    Join Date
    May 2005
    Location
    Melbourne Australia
    Posts
    44
    Quick update. Oil was changed and no more low oil pressure error. Thanks for all the advice guys. I also found the oil filter had started to collapse from the water ingested through the leaking intercooler.
    Also changed the prop to a Skat Trak 14-19 and consistently ran 77.5MPH between 8500 - 8540 all day. Only a small increase top end but massive pull throughout rev range. Cannot believe the acceleration difference.
    Click image for larger version. 

Name:	Screen Shot 2013-01-19 at 11.21.59 PM.jpg 
Views:	362 
Size:	54.8 KB 
ID:	290580

  10. #10
    SLASHER's Avatar
    Join Date
    Jun 2007
    Location
    Australia, Perth WA
    Posts
    3,263
    +1
    474
    Did u install the ET 127 or do mean ET 137 ?

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Low oil pressure msg flashed across lcd '15 px-260
    By Lstorm2003 in forum 4-Tec Performance
    Replies: 3
    Last Post: 07-26-2016, 06:36 PM
  2. Low Oil Pressure Alarm 2005 Seadoo RXT
    By jlk in forum Sea Doo Open Discussion
    Replies: 24
    Last Post: 08-29-2015, 04:50 PM
  3. seadoo low oil pressure on initial startup 2011 gts
    By bigo in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 09-21-2012, 07:01 PM
  4. low oil pressure warning/buzzer
    By zone 5 in forum 4-Tec Performance
    Replies: 2
    Last Post: 09-15-2008, 10:41 PM
  5. Low oil Pressure Sensor Threads
    By kc8lbn in forum Honda How To & FAQs
    Replies: 1
    Last Post: 03-12-2008, 08:47 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •