Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17
  1. #1

    Join Date
    Sep 2007
    Location
    Littleton,NC on Lake Gaston
    Posts
    261
    +1
    23

    Gen3 shaft from riva

    Anyone runing Generation 3 shaft and bearings


  2. #2
    robbiestar's Avatar
    Join Date
    May 2012
    Location
    traralgon vic/ australia
    Posts
    163
    +1
    7
    yep,,,, dont hold back put it in ,,,just dont buy the riva dampener to many failures

  3. #3
    FZS Monty's Avatar
    Join Date
    Apr 2011
    Location
    Eastern Long Island, NY
    Posts
    588
    +1
    37
    Gen-3 is great, get it, you won't regret it. I have no troubles with it, sound engineering too.

  4. #4

    Join Date
    Sep 2007
    Location
    Littleton,NC on Lake Gaston
    Posts
    261
    +1
    23
    Thanks guys for your input

  5. #5
    shhr's Avatar
    Join Date
    May 2005
    Location
    Springfield,TN
    Posts
    2,546
    +1
    311
    for you guys who has installed this did you have to take off the manifold (loosen) to get the oil pressue wire back on I have tried for a hour I cant get that little screw in the end of the oil pressure sensor back on looks like the maifold need to be loose to make it work?? any ideas?

  6. #6
    prostocker's Avatar
    Join Date
    Oct 2012
    Location
    FL
    Posts
    442
    +1
    17
    Not me try to use a dentist mirror and with the tip of your fingers you will be able to do it it took me 30 to 40 minutes of trial and error and i was able to do it without removing the manifold.

  7. #7
    i heard a few guys were having issues with the bearing turning funny colors ? anyone pulled it back out after the install

  8. #8
    JD 1's Avatar
    Join Date
    Aug 2005
    Location
    St. Louis, MO
    Posts
    4,186
    +1
    90
    pull the manifold and do it right way imo. I used a spacer so the tee fitting is tighted, not just free spinning around. this was on a 2013

    I rev mine to 9600+ all the time with zero issue, just pulled the charger tonight and all is perfect...

  9. #9
    yol937's Avatar
    Join Date
    Jul 2011
    Location
    Nc
    Posts
    1,071
    +1
    160
    Plus one it don't take ten mins to pull the mani

  10. +1 by:


  11. #10
    Robert63's Avatar
    Join Date
    Oct 2006
    Location
    Taunton
    Posts
    179
    +1
    4
    You don't have to pull the manifold take out the oil sensor put sensor wire on bolt install into sensor leave about one turn loose in sensor so connector can spin install oil sensor when tight finish tightening the bolt to the wire and you are all done the hole thing takes about 2 minuets

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FS riva gen3 shaft
    By tealgreen2000 in forum Yamaha Classifieds
    Replies: 2
    Last Post: 04-08-2014, 09:19 PM
  2. New Aluminum/SS Billet Impeller Cone from Riva
    By Red Devil in forum 4-Tec Performance
    Replies: 8
    Last Post: 03-09-2006, 05:32 PM
  3. What do you think about the new thermostat from RIVA?
    By Therock in forum 4-Tec Performance
    Replies: 8
    Last Post: 10-01-2005, 12:38 PM
  4. Repitch Solas or the new Solas from Riva
    By Therock in forum 4-Tec Performance
    Replies: 4
    Last Post: 06-23-2005, 08:51 AM
  5. powercooler from Riva
    By UFO-RXT in forum 4-Tec Performance
    Replies: 9
    Last Post: 05-15-2005, 04:27 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •