Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 25
  1. #1
    Impulses's Avatar
    Join Date
    Dec 2011
    Location
    europe
    Posts
    822
    +1
    27

    Angry RIVA KIT 1 and the mystery

    PWC : RXT X 260 RS 2011 european model

    KIT : satge I de RIVA

    Mystery : after three hours with the kit running the pwc only managed 67 miles and 7700 rpm max at sea

    Possible solutions:

    -1 : the scom not working because have not arrived at 5 hours of use

    -2 : Prop 15/20 R of Riva is not adequate because the RXT X 260 RS for OEM use 14/23......

    opinions about it .....
    Click image for larger version. 

Name:	HIGH.jpg 
Views:	100 
Size:	53.6 KB 
ID:	290553Click image for larger version. 

Name:	SEA LEVEL.jpg 
Views:	77 
Size:	53.5 KB 
ID:	290554Click image for larger version. 

Name:	HIGH II.jpg 
Views:	96 
Size:	56.9 KB 
ID:	290555Click image for larger version. 

Name:	SEA LEVEL II.jpg 
Views:	74 
Size:	55.1 KB 
ID:	290556


  2. #2
    West Texas RXP skoepp's Avatar
    Join Date
    Oct 2007
    Location
    west texas
    Posts
    12,019
    +1
    149
    Put more hours on it.

  3. #3
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    Quote Originally Posted by skoepp View Post
    Put more hours on it.
    +1 It should start to come alive at about 5hrs.

  4. #4

    Join Date
    Aug 2008
    Location
    redlake ontario canada
    Posts
    416
    +1
    3
    night and day after 5 hours.

  5. #5
    stuckmoto's Avatar
    Join Date
    Jun 2010
    Location
    Newark, De
    Posts
    1,485
    +1
    59
    Dude, is this the same ski? You stated the ski has 63 hrs on it... the SCOM works immediately. The ECU is only restricted the first 5 hrs of it's INITIAL life.
    2011 RXTX RS

  6. #6
    Impulses's Avatar
    Join Date
    Dec 2011
    Location
    europe
    Posts
    822
    +1
    27
    YEEEEEEESSSSSSSSSS stuckmoto,I have a pwc with total of 63 hours but only 3 hours with SCOM .On page RivaRacing say the SCOM is released from 5 hours and like I said I only took 3 with SCOM.

    http://www.rivayamaha.com/RivaStore/...rride%20Module


    We think it is NOT the SCOM that the problem is the prop,15/20R is too large ....

    I return to the OEM prop?
    I put a 14/23 of SOLAS?

    that is the question not know what to do ....

    P.D: at the dealership did the IC test pressure and compressor and spark plugs and general pwc.

    P.D II : The pwc was mechanically perfect.

    thanks guys

  7. #7
    imp0ster's Avatar
    Join Date
    Dec 2011
    Location
    Palm Harbor, FL
    Posts
    5,037
    +1
    672
    Quote Originally Posted by Impulses View Post
    YEEEEEEESSSSSSSSSS stuckmoto,I have a pwc with total of 63 hours but only 3 hours with SCOM .On page RivaRacing say the SCOM is released from 5 hours and like I said I only took 3 with SCOM.

    http://www.rivayamaha.com/RivaStore/...rride%20Module


    We think it is NOT the SCOM that the problem is the prop,15/20R is too large ....

    I return to the OEM prop?
    I put a 14/23 of SOLAS?

    that is the question not know what to do ....

    P.D: at the dealership did the IC test pressure and compressor and spark plugs and general pwc.

    P.D II : The pwc was mechanically perfect.

    thanks guys
    15/20 is nothing and you should. The kit is designed to work together and NOT put you backwards. Did it do this IMMEDIATELY after installing the SCOM? If so remove it and leave all other parts on. See what you get. Otherwise I smell KR.

  8. #8
    Impulses's Avatar
    Join Date
    Dec 2011
    Location
    europe
    Posts
    822
    +1
    27
    Sorry impOster but what is the KR?
    15/20R definitievamente the pwc with no runs
    SCOM can be the? know if it is working as well?

    Thanks

  9. #9
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    I thought the ski only had 3 hrs. My bad.
    You should be able to spin the crap out of a 15/20r. I would look for a boost leak.
    An after market 15/23 is too much.

  10. #10
    imp0ster's Avatar
    Join Date
    Dec 2011
    Location
    Palm Harbor, FL
    Posts
    5,037
    +1
    672
    Quote Originally Posted by Impulses View Post
    Sorry impOster but what is the KR?
    15/20R definitievamente the pwc with no runs
    SCOM can be the? know if it is working as well?

    Thanks
    knock retard. you should rev limit a 15/20. You probably have an electrical issue since you put on a riva S1 kit and have not(should have had no reason to) touch the supercharger or IC system. Pull the SCOM and keep everything else like I said. give it a run and let us know your revs. Maybe you F'd your MAP somehow

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. ODi grips, Riva bar extensions and the OEM Spark cover
    By edgelett in forum Sea Doo Spark
    Replies: 7
    Last Post: 07-11-2016, 07:27 PM
  2. Replies: 45
    Last Post: 05-07-2012, 11:31 AM
  3. Riva rear air and the exhaust/intercooler options
    By mrbtd in forum 4-Tec Performance
    Replies: 2
    Last Post: 08-26-2010, 05:10 PM
  4. Ocean Jumping and the Riva Through Hull
    By Gforce in forum 4-Tec Performance
    Replies: 13
    Last Post: 08-01-2006, 03:35 PM
  5. With the Stage 1 Riva kit!
    By Angelse68cal in forum 4-Tec Performance
    Replies: 4
    Last Post: 08-31-2005, 05:53 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •