Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 34
  1. #1

    modded rxpx problems :S help

    Okay so today I took my ski for the test run after modding it the last 2 days...

    I installed a 4" air intake with pod, r&d grate, r&d extended steering nozzle, j pipe in the exhaust and filled the ride plate holes...

    Today I took it for a test ride to find out that it hasn't got any better then before... except maybe a bit of middle range... anyways it hits about 90km 7000rpm really fast like it should then once it Hits that speed n rpm it climbs up but very slow and delayed...

    It is also cavitating a little bit... has a new wear ring... the prop clearance is about .297mm... the blades r sharp. The pump seal is fine... the little green washer is looking okay...

    I don't think it should be doing this... any ideas??


    This ski is doing my head in! I'm ready to sell it. The cavitation has been around since I sucked up a rock 40 hrs.ago and I can't get jt fixed!!

    Any help is much appreciated...


  2. #2
    Oh I forgot to mention the veins on the pump shoe snapped so I cut them out...

  3. #3
    Steve STSPERFORMANCE's Avatar
    Join Date
    Dec 2007
    Location
    Cambridge, Ohio
    Posts
    2,701
    +1
    116
    did u smooth the pump shoe after you took the fins off? might wanna post a pic...

  4. #4
    Live to RIDE. brendus's Avatar
    Join Date
    Jan 2008
    Location
    Melbourne, Australia
    Posts
    326
    Try to eliminate the possible problem. I would maybe try switch back to the original intake grate. worth a shot.

  5. #5
    I smoothed out the pump shoe... I posted pics in another thread of mine... don't have them on my phone to post here...

    Surely it wouldn't be the intake grate... the r&d is known for better top end...

    A guy told me that it might be a boost leak why it's playing up... n to check the hoses. .. but that still doesn't explain the endless cavorting

  6. #6
    monaroman76's Avatar
    Join Date
    Mar 2008
    Location
    Whyalla, South Australia
    Posts
    1,979
    +1
    28
    How bad of cavitation are we talking? Have you changed the carbon seal and accordion boot? Also change the spark plugs and check s/c slip if you haven't already.

  7. #7
    lazsrxp's Avatar
    Join Date
    Oct 2012
    Location
    Miami
    Posts
    460
    +1
    3
    I have my spare pump that I'm willing sell

  8. #8
    ADAMBOMB's Avatar
    Join Date
    Mar 2006
    Location
    Sunrise,Florida
    Posts
    4,723
    +1
    196
    Quote Originally Posted by andrewmitchell123 View Post
    Okay so today I took my ski for the test run after modding it the last 2 days...

    I installed a 4" air intake with pod, r&d grate, r&d extended steering nozzle, j pipe in the exhaust and filled the ride plate holes...

    Today I took it for a test ride to find out that it hasn't got any better then before... except maybe a bit of middle range... anyways it hits about 90km 7000rpm really fast like it should then once it Hits that speed n rpm it climbs up but very slow and delayed...

    It is also cavitating a little bit... has a new wear ring... the prop clearance is about .297mm... the blades r sharp. The pump seal is fine... the little green washer is looking okay...

    I don't think it should be doing this... any ideas??


    This ski is doing my head in! I'm ready to sell it. The cavitation has been around since I sucked up a rock 40 hrs.ago and I can't get jt fixed!!

    Any help is much appreciated...
    Why would you put a J pipe on a RXPX?

  9. +1 by:


  10. #9
    imp0ster's Avatar
    Join Date
    Dec 2011
    Location
    Palm Harbor, FL
    Posts
    5,037
    +1
    672
    Bad knock sensor?

  11. #10
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    What rpms are you seeing max?
    As Adam asked. Why would you put a J pipe on the ski?
    Me thinks you have exhaust or boost leak.

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2012 RXPX Problems - oil leaking, water in cylinders - Please Help!!
    By NBD Watersports Inc in forum 4-Tec Performance
    Replies: 1
    Last Post: 08-30-2013, 06:31 AM
  2. kawasaki ultra mods problem! please help
    By clydoudou in forum Kawasaki PWC Performance (4-stroke)
    Replies: 14
    Last Post: 07-21-2013, 11:10 PM
  3. Need help! '08 RXPX problem
    By DCoog in forum 4-Tec Performance
    Replies: 13
    Last Post: 06-28-2009, 09:13 PM
  4. Crazy Problem with RXPX display..Please Help?
    By RXTJeff in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 07-03-2008, 09:38 PM
  5. Mod your ski and help the site at the same time!
    By Green Hulk in forum 4-Tec Performance
    Replies: 54
    Last Post: 08-25-2005, 02:42 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •