Page 1 of 2 1 2 LastLast
Results 1 to 10 of 20
  1. #1
    quiddo15's Avatar
    Join Date
    Aug 2012
    Location
    Sydney Australia
    Posts
    752
    +1
    109

    I need help urgently with my rxpx 2009!

    I start the ski and as i pull the throttle in it chokes, then I try to gradually pull it in and gets to about 6000rpm and won't go any harder. So from there I put new spark plugs in the ski, had the injectors cleaned, checked the slip on the charger, checked the Rrfpr and it's abit over 50psi where it should be, so then I check the oil catch can and it's full, from previous experiences this is a bad sign. The ski has 36hrs on it , it has just had seadoo centre low comp pistons put in it and was last used and tuned by Garry Watson.


  2. #2
    GasResearch-VT.SE's Avatar
    Join Date
    Nov 2012
    Location
    Melbourne, Australia
    Posts
    1,172
    +1
    207
    Check comp.
    Put a bore scope in the spark holes, have a look.
    Check for water leaks from head gasket.

    Thats just a few things.

  3. #3
    sniper300's Avatar
    Join Date
    Apr 2009
    Location
    Perth Western Australia
    Posts
    165
    +1
    6
    Check your manifold !!! it may have a big leak or has split. When i split mine it would not rev over 6200rpm!! Are you running big boost ?? as that would be the only reason you would run low comp pistons!!

  4. #4
    GasResearch-VT.SE's Avatar
    Join Date
    Nov 2012
    Location
    Melbourne, Australia
    Posts
    1,172
    +1
    207
    Good point... I just had that last week!
    Anything over 13 psi is asking for trouble with the manifold, some will be lucky and hold, some won't (like mine).

    Blow 15-30 psi through the intake piping using a low volume air compressor or 15 psi using a high volume, this is how I found where mine leaked.
    I tried 5psi but it didn't show the problem.

  5. #5
    quiddo15's Avatar
    Join Date
    Aug 2012
    Location
    Sydney Australia
    Posts
    752
    +1
    109
    Yeah I'm running a Seadoo centre c kit, it's puting out about 20psi at the manifold, the ski has just had a Brand new seadoo centre aluminum race manifold all brand new titanium valves, bored throttle body to 60mm. All the gear is brand new. The catch can had a a fair bit of oil in it.

  6. #6
    Boost-A-Holic's Avatar
    Join Date
    Jul 2012
    Location
    Dallas, Texas, United States
    Posts
    1,173
    +1
    94
    Quote Originally Posted by quiddo15 View Post
    I start the ski and as i pull the throttle in it chokes, then I try to gradually pull it in and gets to about 6000rpm and won't go any harder. So from there I put new spark plugs in the ski, had the injectors cleaned, checked the slip on the charger, checked the Rrfpr and it's abit over 50psi where it should be, so then I check the oil catch can and it's full, from previous experiences this is a bad sign. The ski has 36hrs on it , it has just had seadoo centre low comp pistons put in it and was last used and tuned by Garry Watson.
    when u say last used how long ago was that? old gas maybe? sounds like it isnt but i just had to stick it out there. When i first went to go check out my ski before purchase i test rode it and even though we added fresh fuel there was still some old fuel in the tank/lines and it did the exact same thing urs is doing for a bit.

  7. #7
    quiddo15's Avatar
    Join Date
    Aug 2012
    Location
    Sydney Australia
    Posts
    752
    +1
    109
    Ok so the ski had not been ridden in about a year, then i rode it with old fuel in the tank, then I emptied the old fuel out and put new fuel in, then changed the spark plugs, and had the injectors cleaned and still the same problem but this time the catch can filled up with oil and even over flowed into the hull of the ski. Thanks for help guys.

  8. #8
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    Run a double dose of Injector cleaner to clean fuel lines and check your oil.

    Oil might be over full??

  9. #9
    quiddo15's Avatar
    Join Date
    Aug 2012
    Location
    Sydney Australia
    Posts
    752
    +1
    109
    So your saying to run Injector cleaner into my fuel tank? I've read that this could be harmful for the engine and also i'd have to change the oil in the ski after running it.

  10. #10
    quiddo15's Avatar
    Join Date
    Aug 2012
    Location
    Sydney Australia
    Posts
    752
    +1
    109
    I just checked the oil and the level is double what it usually is and it looks like the garret intercooler has sucked up water Would it just be a matter of getting the water out of the engine and replacing the intercooler??

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need help please with my Rrfpr
    By quiddo15 in forum 4-Tec Performance
    Replies: 15
    Last Post: 02-25-2013, 06:00 AM
  2. Help me with my next mod!
    By Yellow93 in forum Yamaha PWC Performance (2-stroke)
    Replies: 16
    Last Post: 06-09-2006, 11:07 PM
  3. Can anyone help me with my impeller shaft and new prop?
    By ccassone in forum 2-Stroke Performance
    Replies: 0
    Last Post: 02-10-2006, 03:45 PM
  4. Sombody PLEASE help me with my @#$%@# pump!
    By NeVerMind in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 12-02-2005, 03:06 PM
  5. NEED HELP URGENT(HULK) RXP DOWN
    By macattack in forum 4-Tec Performance
    Replies: 28
    Last Post: 11-22-2005, 02:39 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •