Results 1 to 10 of 10
  1. #1

    RPM problem on 300x

    Need assistance with my 300x. The RPM only goes up to 7,200. My jet donīt run more than 61 mph. The boost goest up to 12 - 13. It has all performance parts including the scom. checked all lines without any problems. It sound perfect. Please assist,


  2. #2
    Moderator #985 lasportsmn's Avatar
    Join Date
    Oct 2008
    Location
    Pierre Part, Louisiana
    Posts
    4,780
    +1
    358
    check your hose clamps on both hoses of your air intake system. the red hose from SC to intercooler and the short black hose between the IC and throttle body. Usually the place to start with this.

  3. #3
    Thanks for your information. Already did and all seems to be right. Any other suggestion, very welcome. Thanks again

  4. #4
    Moderator #985 lasportsmn's Avatar
    Join Date
    Oct 2008
    Location
    Pierre Part, Louisiana
    Posts
    4,780
    +1
    358
    Is everything up to that point running well? when on the water, pump needs to be loaded, does it spike then drop back down or that is all it climbs to then holds there?

  5. #5
    jet ski running well. thatīs all it climb and hold there

  6. #6
    UltraKvz's Avatar
    Join Date
    Feb 2011
    Location
    Earth
    Posts
    378
    +1
    23
    What is your air + water temp, elevation? Under certian atmospheric conditions you will not notice any diffrence with the scom. 7200 rpm will show only 12 - 13 psi.

  7. #7
    Self Confessed Day Dreamer toomanytoys's Avatar
    Join Date
    Sep 2008
    Location
    Sydney, Australia
    Posts
    1,932
    +1
    151
    When you say it has all performance parts, what's "all".

    If you are running a 15/22 impeller on a hot day with hot water that could almost be normal.

    How many hours on your ski? Have you checked your exhaust filter? If that fails you can lose a couple of hundred RPM too.

    What RPM have you seen in the past (with all these "performance" parts fitted)?

    Cheers, Mal.

  8. #8
    My sky is 46 hrs. I have installed: scom, ride place, intake great, air intake, 1 degree spacer, block off, riva waterbox, etc. It used to run 72-73 mph.
    Perhaps something in the computer?

  9. #9
    Have you ever cleaned the intercooler? If not, might give that a try. We had a guy in our group that was way down on RPMs and once he cleaned the IC he was right back.

  10. #10
    Self Confessed Day Dreamer toomanytoys's Avatar
    Join Date
    Sep 2008
    Location
    Sydney, Australia
    Posts
    1,932
    +1
    151
    7200 RPM on a stock prop is too low.

    A dirty IC might pull a couple hundred RPM's, that's not likely to be the cause (but worth cleaning it out now anyway).

    If you've lost your Exhaust Filter, given you have the RIVA waterbox, it may have gone though it and lodged partly in the exhaust pipe. You'd lose many hundreds of RPM's if that happened (because of the RIVA Waterbox it could choke the exhaust flow easy and you could lose even more or cause the ski to barely run). Even a stock waterbox, with the filter wedged in it, you'll lose a few hundred RPM.

    Cheers, Mal.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Ultra 300X rpm Problem...
    By RXP-X 2011 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 4
    Last Post: 05-11-2015, 06:20 AM
  2. new 2012 300x rpm problem only 14 hours
    By shorerider in forum Kawasaki PWC Performance (4-stroke)
    Replies: 15
    Last Post: 06-20-2014, 07:08 PM
  3. speed problem on my 300x
    By Gian in forum Kawasaki PWC Performance (4-stroke)
    Replies: 9
    Last Post: 05-28-2013, 03:31 PM
  4. problem on my 300x IC
    By Gian in forum Kawasaki PWC Performance (4-stroke)
    Replies: 52
    Last Post: 04-30-2013, 12:55 PM
  5. A few Problems Low RPMS & Starting on it's own
    By Kaotic in forum 4-Tec Performance
    Replies: 7
    Last Post: 06-01-2009, 11:30 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •