Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 22
  1. #1

    i need some help guys...2002 polaris 800di virage..help

    I bought a 2002 polaris 800di virage..the guy said that the jet ski runs sometimes and sometimes struggles to start..once it is ridden for a while it works fine..but its hard to start. I took it to a non certified mechanic and he says everything looks good..that it might be computer..he said he cleaned fuel lines..checked injectors..and that motor has good compression..so I need some help..when I start it in my garage with waterhose..I have to play with throttle alot just to get it on and keep it on..it doesn't stay on by itself...help me please..thank you for your time guys


  2. #2
    PWC Addict lilman573's Avatar
    Join Date
    Feb 2010
    Location
    Central NJ
    Posts
    2,946
    +1
    207

    Re: i need some help guys...2002 polaris 800di virage..help

    Have the same ski and had the same problem. It will most likely end up being the Emm, but there are certain things to test before taking it out to be sent out. There is only one company, DFI, that fixes them and its about 6-700 dollars.

    There are links to all the tests in K447's signature. Let me find them to repost.

    Good luck!

  3. #3
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    Disconnect the TPS and see if it starts/runs. You will not have throttle control though, it will just idle.

  4. #4
    I'm sorry guys..this is all new to me..I don't know where the tps sensor is..so what is the consecuence for removing the tps sensor..what happens..how do I know if I need new tps sensor..how much and where..thanks guys

  5. #5
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    If you unplug it and the engine starts and idles normally, it tells you the TPS is bad. Its located on the end of the throttle body, and has a wire harness with a plug coming out of it. It comes off with 2 screws. K447 has a picture of one as his avatar. I think they are around 100 bucks from a Polaris dealer.

  6. #6
    Would you think its either that tps problem or computer problem..is the computer called emm or what?

  7. #7
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    Quote Originally Posted by phazek View Post
    Would you think its either that tps problem or computer problem..is the computer called emm or what?

    Yes the computer is the EMM. If the TPS doesn't solve it, I would check fuel pressure next.

  8. #8
    I was told there is fuel pressure...my brother in law says he took the tps sensor off and it still wouldn't start..

  9. #9
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    There may be fuel pressure, but not enough.

  10. #10
    So what should I do..I hate being so clueless about this..any advice guys

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. i need some help guys...2002 polaris 800di virage..help
    By phazek in forum Polaris PWC Performance
    Replies: 15
    Last Post: 02-04-2013, 07:54 AM
  2. 2002 polaris 800di virage help..help..help
    By phazek in forum Polaris Tech Tips and Info
    Replies: 1
    Last Post: 02-03-2013, 08:41 PM
  3. need some help from the US guys
    By winterstick in forum Polaris Open Discussion
    Replies: 3
    Last Post: 04-28-2007, 09:47 PM
  4. need some help guys...
    By minersny in forum Polaris Open Discussion
    Replies: 6
    Last Post: 03-24-2007, 01:00 PM
  5. Need some help guys, Lost 500rpm
    By CRS in forum 4-Tec Performance
    Replies: 13
    Last Post: 05-15-2006, 05:24 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •