Results 1 to 6 of 6
  1. #1

    Valve cover gasket out of place and no compression

    Here is the weird thing. A friend of mine, 11 Ultra 300LX 55 hours, got a low oil pressure warning in a middle of a WOT run. He shut it down right away. We opened the engine compartment and lots of smoke and oil all over. We started looking around and the valve cover rubber gasket was out of place. Took plugs out and seems that the No. 4 piston has no compression, or very low compared to the others.

    For this run we had just installed ride plate, grate, block off, little filter for the waste gate. We are leaning towards the Block off but I have the same thing with no issues. Any ideas?

    Jay


  2. #2
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,794
    +1
    625
    sounds like it has deto'd a piston or dropped a valve, crankcase pressure will blow the gasket out

  3. #3
    Banned User
    Join Date
    Jan 2009
    Location
    LA/oc
    Posts
    3,911
    +1
    129

    Valve cover gasket out of place and no compression

    X2. Another one bites the dust. Time to tear it apart.

  4. #4
    yes RD Scom, no speedo spacer. RD plate and grate

  5. #5
    Vman's Avatar
    Join Date
    Nov 2005
    Location
    NJ
    Posts
    4,363
    +1
    339
    Time for a compression + leakdown test. Sounds like it's gonna have to come apart. Sorry.

  6. #6
    stangbang's Avatar
    Join Date
    Oct 2007
    Location
    West Palm Beach
    Posts
    844
    +1
    129
    Quote Originally Posted by Vman View Post
    Time for a compression + leakdown test. Sounds like it's gonna have to come apart. Sorry.

    Check it again. My buddy did the same thing and was freaking out. I put the gasket back in and tested it and came up with good compression. This happened two years ago and the ski still runs like a champ. I'm still not sure how he got a low compression reading, but thank god he was wrong.

    Good luck.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 97 SeaDoo GTX runs out of water but no power & max rpm @ 3200 in water
    By Irish Democrat in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 08-14-2009, 09:00 AM
  2. HELP Valve cover gasket
    By beachbum0286 in forum 4-Tec Performance
    Replies: 6
    Last Post: 05-10-2008, 12:36 PM
  3. Valve cover gasket leaking oil
    By EGGonz in forum Kawasaki PWC Performance (4-stroke)
    Replies: 0
    Last Post: 09-15-2007, 10:04 AM
  4. Running out of ideas and patience with 98 GTX RFI
    By Tonic in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 08-13-2007, 02:18 PM
  5. how do i get smell out of gloves and shoes?
    By cue03 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 7
    Last Post: 04-24-2007, 08:47 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •