Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 34

Thread: B kit failure

  1. #1
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182

    B kit failure

    here's a few pics of touchdown from bearing failure on my B kit SC. I had this less than a year, just over 100 hrs or so on it. It bent the SC shaft, and some of the bearing pieces went in the engine . Looks like it will need a flywheel also. Time to pull the engine.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	100_0905.jpg 
Views:	85 
Size:	730.4 KB 
ID:	16829   Click image for larger version. 

Name:	100_0902.jpg 
Views:	69 
Size:	632.6 KB 
ID:	16830   Click image for larger version. 

Name:	100_0909.jpg 
Views:	95 
Size:	780.3 KB 
ID:	16831   Click image for larger version. 

Name:	100_0899.jpg 
Views:	86 
Size:	395.6 KB 
ID:	16832  


  2. #2
    Banned User
    Join Date
    Dec 2006
    Location
    Crest Hill, IL
    Posts
    9,512
    +1
    215
    Again? i got pics from the last time the shaft bent and you needed a flywheel...I was the one who took it apart!

  3. #3
    Moderator The Bandit's Avatar
    Join Date
    Jul 2006
    Location
    Wilmette, IL
    Posts
    8,373
    That sucks.

  4. #4
    WOW , looks like you`ll be needing a SC as well, sorry to hear that!...PR...

  5. #5
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    B kits are very expensive, so are the rude ones. I'm going to try to salvage this one, and go with a new 06' kit with metal clutches, and soon ceramic bearings . If anyone has 100hrs or more on your SC'ers Please do yourself a favor, and pull em to check the bearing play! Especially @8500rpms

  6. #6
    beached log's Avatar
    Join Date
    Oct 2006
    Location
    Ft lauderdale
    Posts
    176

    sorry 4 your loss !!

    i have posted this many times before !! but i'll say it once again in my opinion the low clearance SCs like the b-kit and the c-kit should be maintained every 20-30 hours , by that i mean new bearing and clutch adjustment ! i think the fact that u got a 100hrs out of yours is pretty good , i've seen blown b-kits with 30 hours . hey ask jerry if u can put a RUDE charger impeller and cover to fix your b-kit !! it might fit !

  7. #7
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    Quote Originally Posted by Danny View Post
    Again? i got pics from the last time the shaft bent and you needed a flywheel...I was the one who took it apart!
    yup, the same kind of failure, not as bad this time, but still bad enough . I still have that new SC from that rebuild as a spare(very low use)and when installed I hear a grinding noise when it turns over .....Not good! It runs with no charger in it tho....lol

  8. #8
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    hey ask jerry if u can put a RUDE charger impeller and cover to fix your b-kit !! it might fit !
    Jerry, or nills, or whoever...... is this a possibility? How much?

  9. #9
    Banned User
    Join Date
    Dec 2006
    Location
    Crest Hill, IL
    Posts
    9,512
    +1
    215
    Quote Originally Posted by psycho rxp View Post
    yup, the same kind of failure, not as bad this time, but still bad enough . I still have that new SC from that rebuild as a spare(very low use)and when installed I hear a grinding noise when it turns over .....Not good! It runs with no charger in it tho....lol
    I remember that ride, we got about 1 mile from the launch ramp and you though the clutches went...when it turned out to be the slippery rubber connections on the tubes, kept blowing off! I remember running it on that one river back at your place and having it blow when at 8350, and the seat popping up and it going to 6400! LOL!

  10. #10
    Moderator The Bandit's Avatar
    Join Date
    Jul 2006
    Location
    Wilmette, IL
    Posts
    8,373
    I am suddenly feeling alot better about my ceramic bearing purchase.

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Riva RPM Kit Failures
    By Toby in forum Kawasaki PWC Performance (4-stroke)
    Replies: 17
    Last Post: 06-19-2008, 06:29 AM
  2. anybody running Riva Supercharged Sea Doo RXT Stage I Kit
    By jonstephens in forum 4-Tec Performance
    Replies: 7
    Last Post: 05-17-2005, 05:14 PM
  3. Flush Kit
    By Vern in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 05-11-2005, 01:36 AM
  4. opas block off kit?
    By wakeborder556 in forum 4-Tec Performance
    Replies: 2
    Last Post: 05-09-2005, 10:29 PM
  5. which stage 2 kit?
    By maildude in forum 4-Tec Performance
    Replies: 3
    Last Post: 05-02-2005, 12:51 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •