Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 25

Thread: Sudden rpm drop

  1. #1
    AmishFZS's Avatar
    Join Date
    Jun 2012
    Location
    Dar Es Salaam, Tanzania
    Posts
    134
    +1
    1

    Sudden rpm drop

    I was riding my ski for at least 3 hours one day.. and right before getting back into shore. My ski would not rev above 5000 rpm.... Took it out again yesterday and still the same... What should i be looking at?

    *injectors?
    *clutch?

    these are the only two things i can think of. Please advise.


  2. #2
    Kelly_A's Avatar
    Join Date
    Dec 2009
    Location
    Central Oklahoma
    Posts
    660
    +1
    17
    does it otherwise accelerate/run normally? Is the onboard diagnostic showing any codes?

  3. #3
    AmishFZS's Avatar
    Join Date
    Jun 2012
    Location
    Dar Es Salaam, Tanzania
    Posts
    134
    +1
    1
    it accelerated fine... but didn't feel any power and the rpm stops around 5000 rpm...felt like i was on a 1100cc.... the onboard diagnostic didn't show any errors.

  4. #4
    AmishFZS's Avatar
    Join Date
    Jun 2012
    Location
    Dar Es Salaam, Tanzania
    Posts
    134
    +1
    1
    i had also changed the spark plugs, could it be the supercharger shaft?

  5. #5
    FZS Monty's Avatar
    Join Date
    Apr 2011
    Location
    Eastern Long Island, NY
    Posts
    588
    +1
    37
    what oil are you using? i had same symptom when i used synthetic, reuslted in a slipping sprag clutch.

  6. #6
    AmishFZS's Avatar
    Join Date
    Jun 2012
    Location
    Dar Es Salaam, Tanzania
    Posts
    134
    +1
    1
    To be very honest i am not sure... nut i purchase the oil from the Yamaha dealer.... and i have actually never had a problem... even the other 8 skis that i service we've all used the same oil..

  7. #7
    robbiestar's Avatar
    Join Date
    May 2012
    Location
    traralgon vic/ australia
    Posts
    163
    +1
    7
    sounds like clutch to me , pull your air intake off and put ur finger in the super charger and see if the sc impeller turns both ways it should only turn one way if it gos both ways the clutch is gone

    p.s dont run the motor while your finger is in the sc
    Last edited by robbiestar; 02-11-2013 at 06:54 AM.

  8. #8
    AWA MEMBER
    Join Date
    Jan 2008
    Location
    Currituck, North Carolina, United States
    Posts
    4,616
    +1
    247
    Quote Originally Posted by FZS Monty View Post
    what oil are you using? i had same symptom when i used synthetic, reuslted in a slipping sprag clutch.




    I never had that problem with synthetic oil? I run Amsoil Synthetic Motorcycle oil 10W40........it has no friction modifiers in it

  9. #9
    THE PLATE MAN JIM'S PERFORMANCE's Avatar
    Join Date
    Nov 2005
    Posts
    6,194
    +1
    536
    it's a clutch problem, on a 2011 it could be the teeth broke off.

  10. #10
    AmishFZS's Avatar
    Join Date
    Jun 2012
    Location
    Dar Es Salaam, Tanzania
    Posts
    134
    +1
    1
    The really weird thing is that.. a friend and I both were out riding for 3 hours... on our way back.. literally at the same time both of our skis had a sudden drop of rpm... we had stopped to have a small word... as soon as we fired up both of our rpms stuck at 5,000

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Stage 2 GP12R RPM drop at WOT
    By Himes in forum Yamaha PWC Performance (2-stroke)
    Replies: 18
    Last Post: 05-27-2010, 11:05 PM
  2. Sudden RPM drop off around 3900
    By LakeDog in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 08-14-2008, 11:33 AM
  3. Help 07 Sc Wake Rpm Drop While Surging
    By Scotty in forum 4-Tec Performance
    Replies: 13
    Last Post: 10-10-2007, 10:20 PM
  4. 13/18 Solas/SS Wear Ring = 700 rpm drop from stock 10/21 :(
    By clpsuite in forum 4-Tec Performance
    Replies: 11
    Last Post: 08-09-2007, 09:00 PM
  5. Loss Of Power/RPM Drop
    By ph2ocraft in forum Polaris Open Discussion
    Replies: 13
    Last Post: 06-26-2007, 12:44 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •