Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 29
  1. #1
    Self Confessed Day Dreamer toomanytoys's Avatar
    Join Date
    Sep 2008
    Location
    Sydney, Australia
    Posts
    1,932
    +1
    151

    Thumbs up New 2013 Ultra 300x Exhaust Filter has arrived

    Hey guys,

    I thought you all might be interested in this.

    It's the new 2013 Exhaust Filter (arrived today).

    The most obvious thing is the hole in the centre. The less noticeable changes seem to be the element pattern (but I could be wrong) and the casing seems to be a higher quality Stainless Steel (but again, I could be wrong).



  2. #2
    Banned User
    Join Date
    Jan 2009
    Location
    LA/oc
    Posts
    3,911
    +1
    129

    New 2013 Ultra 300x Exhaust Filter has arrived

    Think the hole is for the dowel pin to sit in on the 13 manifold. But yes it should last longer. With better materials / design now

  3. #3
    Olomana's Avatar
    Join Date
    Jan 2011
    Location
    Tahiti, French Polynesia
    Posts
    1,414
    +1
    76
    Do you have the part number for it ?! thanks!

  4. #4
    Vman's Avatar
    Join Date
    Nov 2005
    Location
    NJ
    Posts
    4,363
    +1
    339
    Seems like that hole in the center would just allow more moisture through the filter and up into the head.

  5. #5
    Self Confessed Day Dreamer toomanytoys's Avatar
    Join Date
    Sep 2008
    Location
    Sydney, Australia
    Posts
    1,932
    +1
    151
    Yep, new part number is: 16104-0012

  6. #6
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,794
    +1
    625
    just double check the welds dont foul when you install mal, nice work

  7. #7
    Self Confessed Day Dreamer toomanytoys's Avatar
    Join Date
    Sep 2008
    Location
    Sydney, Australia
    Posts
    1,932
    +1
    151
    Yeah, will do. I only just put a replacement in (old style) so I won't be installing this for maybe 40 hours or so (or in a few months). I'm finding mine have been failing at around 50 hours. Cheers.

  8. #8
    dw_1's Avatar
    Join Date
    Jan 2012
    Location
    Sydney Australia
    Posts
    235
    +1
    4
    hey anybody know whats the go with this product? http://www.4-tecperformance.com/inde...oducts_id=1910

  9. #9
    Banned User
    Join Date
    Aug 2009
    Location
    Discovery Bay, CA
    Posts
    3,048
    +1
    336
    Most vote no on this one. Makes it hard to start after sitting in the water a while along with other issues

  10. #10
    Self Confessed Day Dreamer toomanytoys's Avatar
    Join Date
    Sep 2008
    Location
    Sydney, Australia
    Posts
    1,932
    +1
    151
    When your exhaust filter breaks you essentially have this product. For me I immediately notice the harder starts. I'd probably avoid this product for rec riding.

  11. +1 by:


Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Ultra-300x Exhaust Filter - GONE at 50-Hour Interval
    By Spooling in forum Kawasaki How To & FAQs
    Replies: 39
    Last Post: 07-28-2017, 07:57 PM
  2. Ultra-300x Exhaust Filter - GONE at 50-Hour Interval
    By Spooling in forum Kawasaki PWC Performance (4-stroke)
    Replies: 38
    Last Post: 06-24-2016, 07:27 AM
  3. My 2013 Ultra 300x book has a Misprint in Spark plug Torque setting page 151
    By rod_rod in forum Kawasaki PWC Performance (4-stroke)
    Replies: 3
    Last Post: 08-26-2015, 11:45 PM
  4. Ultra-300x Exhaust Filter Inspection
    By Spooling in forum Kawasaki PWC Performance (4-stroke)
    Replies: 3
    Last Post: 05-03-2013, 05:04 PM
  5. Ultra 300X Exhaust Filter w/pics
    By toomanytoys in forum Kawasaki PWC Performance (4-stroke)
    Replies: 115
    Last Post: 10-09-2012, 05:08 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •