Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 40
  1. #1

    Join Date
    May 2010
    Location
    Jax,FL
    Posts
    3,438
    +1
    652

    R&D Exhaust Manfiold X-Tender - FAIL?

    So I installed it on my 2012 RXPX;
    Click image for larger version. 

Name:	DSCN0676.JPG 
Views:	216 
Size:	228.5 KB 
ID:	292815

    It now pushes the water box so close to that motor.
    Click image for larger version. 

Name:	DSCN0682.JPG 
Views:	201 
Size:	237.7 KB 
ID:	292816

    This it not ok is it?


  2. #2
    Water4fire's Avatar
    Join Date
    May 2005
    Location
    New Braunfels TX.
    Posts
    10,058
    +1
    790
    Did you drill your bell houseing out on your manifold? Because it can not read propperly through metal and yes I think your exhaust is fine.

  3. #3

    Join Date
    May 2010
    Location
    Jax,FL
    Posts
    3,438
    +1
    652
    Quote Originally Posted by Water4fire View Post
    Did you drill your bell houseing out on your manifold? Because it can not read propperly through metal and yes I think your exhaust is fine.
    No. I called and talked to R&D about the install and that very issue and they told me it work just fine. It seems like there is enough gap around it that it will get exhaust gas circulated around it.

  4. #4
    Water4fire's Avatar
    Join Date
    May 2005
    Location
    New Braunfels TX.
    Posts
    10,058
    +1
    790
    They are wrong. Period. I will promiss you this. I had it and used it and it would not read propperly until I drilled the exhaust bell houseing. Sorry this is true use input.

  5. #5
    RXP 260 X Short Course Veteran RXP244's Avatar
    Join Date
    May 2007
    Location
    Auckland, New Zealand, New Zealand
    Posts
    1,244
    +1
    104
    Quote Originally Posted by DinoMite View Post
    Quote Originally Posted by Water4fire View Post
    Did you drill your bell houseing out on your manifold? Because it can not read propperly through metal and yes I think your exhaust is fine.
    No. I called and talked to R&D about the install and that very issue and they told me it work just fine. It seems like there is enough gap around it that it will get exhaust gas circulated around it.
    I will agree with R&D that there is enough of a gap too allow exhaust gas to circulate around the sensor, but I wouldn't be happy unless the sensor was fully in the exhaust flow. This is the only way I would be happy that the sensor was reading correctly.

  6. #6
    RipNSki's Avatar
    Join Date
    Jul 2008
    Location
    SE MN on the Mississippi River
    Posts
    734
    +1
    5
    I was told you only had to drill it if you didn't have an X boat... I plan to put one on soon also... water was your install on an X boat???

    Ripper

  7. #7
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    I personally wouldn't want my waterbox banging up against that $1200 iBR module. Why not just do it the right way, and pull your exhaust manifold off to drill & tap it?

  8. +1 by:


  9. #8
    83.0 @ 8400 jhill19's Avatar
    Join Date
    Jul 2010
    Location
    Teays Valley, West Virginia
    Posts
    2,800
    +1
    81
    Quote Originally Posted by RipNSki View Post
    I was told you only had to drill it if you didn't have an X boat... I plan to put one on soon also... water was your install on an X boat???

    Ripper
    All exhaust manifolds have the bell on the end you're not going to pick up a reading from your o2 sensor unless you drill that bell since the extender puts the sensor right over that bell.

  10. #9
    RipNSki's Avatar
    Join Date
    Jul 2008
    Location
    SE MN on the Mississippi River
    Posts
    734
    +1
    5
    I spoke to jerry on this and his response to me was it will work fine on my 09 rxp-x boat without having to drill anything... I'm not sure where/how to drill it the Bell or manifold on my boat so that is why I went this option... It doesn't say anything on the description of the X tender that something also has to be drilled... I'm gonna trust what Jerry wrote to me and not try to drill anything...

    Jerry let us know if whe have to drill something... (Now I'm worried...since my whole set up will hinge on AFR readings...)

    Ripper

  11. #10
    Water4fire's Avatar
    Join Date
    May 2005
    Location
    New Braunfels TX.
    Posts
    10,058
    +1
    790
    Forgive me for being blunt, and I respect everyones input, but I have used the DANG thing and it was a JOKE to get readings. They would bounce all over the place and just NOT read correctly. PERIOD! this is not me being a key board internet wanna BE. this is me telling you I have had it and it just did not work correctly until I Drilled the Bell houseing.

  12. +1 by:


Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. WTB i need R&D Exhaust Manifold X-Tender / O2 Sensor
    By stevorxp007 in forum Sea Doo Classifieds
    Replies: 3
    Last Post: 03-12-2010, 02:58 AM
  2. WTB R&D Exhaust Manifold X-Tender / O2 Sensor Mount Kit
    By stevorxp007 in forum Sea Doo Classifieds
    Replies: 2
    Last Post: 11-23-2009, 06:37 PM
  3. WTB R&D Exhaust Manifold X-Tender
    By jayohentran in forum Sea Doo Classifieds
    Replies: 3
    Last Post: 11-17-2009, 03:23 PM
  4. Replies: 1
    Last Post: 10-04-2009, 10:36 PM
  5. rxp-x exhaust manfiold bolts
    By Ocman in forum 4-Tec Performance
    Replies: 5
    Last Post: 04-30-2009, 10:05 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •