Results 1 to 9 of 9
  1. #1

    2005 rxp engine making popping sound... Need help!!

    So I decided to take my rxp out today and see how the surf was. She was running great with the exception of this popping that would occur around 4-5k rpm. Idle is smooth, and wot is revving out to 7900rpm. When the pop would happen, i would loose like 200rpm and then it would jump right back to previous rpm. I would bring the motor to ~6k and it wouldn't do it. New plugs with 1 hr on them. Anyone ever have an occurrence like this or have any insight into what's going on?

  2. #2
    Check to see if you blew your supercharger hose off.

  3. #3
    Having Fun jp1300r's Avatar
    Join Date
    Sep 2005
    How do the coils look? Maybe shorting out.

  4. #4
    Supercharger discharge hose is good.

  5. #5
    Just replaced all the coils a few months ago. Ill try to take it out tomorrow and put my coils from my 2008 in there and make sure it's not that. Thanks for the input

  6. #6
    speedskixp's Avatar
    Join Date
    Feb 2008
    venice fl.
    Dirty injector maybe.

  7. +1 by:

  8. #7

    Join Date
    Mar 2006
    old gas or gas with stabil? First ride of the year from storage?

  9. #8
    AtoMIC_OraNGE greenbullet's Avatar
    Join Date
    Jul 2010
    Barrie / BuckHORN Ontario
    check your injectors like speedski said.... sounds like may be a lean pop at those rpms.. ive had it before....

  10. #9
    Fresh gas. I run it about 3 times a month. Ill pull the injectors to make sure the spray is good and ill swap them for my 42# injectors to see if it helps.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 04 RXP Sensor light Code P1517 Need Help/Advice on Removal Please Read
    By davidrxp in forum Sea Doo Open Discussion
    Replies: 16
    Last Post: 12-03-2013, 08:22 PM
  2. RXP 2006 with stage III ..need help in error 1544
    By enriquealonso1 in forum 4-Tec Performance
    Replies: 6
    Last Post: 11-16-2010, 05:01 PM
  3. RXP 3/4 under water need help ASAP
    By rockonup in forum 4-Tec Performance
    Replies: 1
    Last Post: 08-15-2010, 04:23 PM
  4. 2005 GP1300R wont start (no spark) - Need help
    By arielsdv in forum Yamaha PWC Performance (2-stroke)
    Replies: 43
    Last Post: 04-25-2009, 03:28 PM
  5. 2005 RXP Stage III Header/Manifold meltdown HELP
    By inteljd in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 06-03-2007, 12:26 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts