Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 22
  1. #1

    Join Date
    Sep 2010
    Location
    Aliso Viejo
    Posts
    951
    +1
    75

    ECU Issues and Remote Question

    Hey Guys,

    How many of you have had to replace ECU due to ECU acting up. I'd like to know how it affected your ski.

    Second question: If I change my ECU, do I need to reprogram the remotes or ECU and remotes are not related?

    I am having a weiredest problem, once in a while and for a short time, ski drops a cylinder and it will come back again if I play with throttle. Everything shows Normal on YDS, it's not the coils or plugs...Most likely not the wire harness either. Low hours ski 89 and ECU issues...sucks!

    Thanks!


  2. #2
    AWA MEMBER
    Join Date
    Jan 2008
    Location
    Currituck, North Carolina, United States
    Posts
    4,616
    +1
    247
    The remotes are independant that control is up front on right side on a FZR/FZS behind white wall.......all that does is inmobilize the starter

  3. #3

    Join Date
    Sep 2010
    Location
    Aliso Viejo
    Posts
    951
    +1
    75
    Thanks Rick! My friend who is a Yamaha technician texted me and said the same thing as you. That's good news. The ECU is not so good news for me but before buying one I will keep looking for other reasons that may cause my issue.

  4. #4
    AWA MEMBER
    Join Date
    Jan 2008
    Location
    Currituck, North Carolina, United States
    Posts
    4,616
    +1
    247
    Look for intermittent wire connections in your harness....rubbing or chaffing against engine, intake manafold.........

  5. #5

    Join Date
    Sep 2010
    Location
    Aliso Viejo
    Posts
    951
    +1
    75
    I have but I will continue doing so. I will disconnect every single connector and look at them visually as well. If this was a wiring problem, I would think it would happen in choppy days more often but no matter what, it won't happen until I have 15-20 miles of riding...The weirdest thing is when it happens, all I need to do is either slow down on throttle or jam the throttle and it plays and goes away. Everytime it has happened at about 8-8.5K RPM.

  6. #6

    Join Date
    Sep 2010
    Location
    Aliso Viejo
    Posts
    951
    +1
    75
    Yamaha skis suck!!! You ask why? Because they don't break down enough and often so everyone knows what the heck is wrong with them when they do ...LOL Sad but true because I have asked a few different dealers with no luck,,,,

  7. #7
    AWA MEMBER
    Join Date
    Jan 2008
    Location
    Currituck, North Carolina, United States
    Posts
    4,616
    +1
    247
    Think it has something to do with motor throttle body?

  8. #8

    Join Date
    Sep 2010
    Location
    Aliso Viejo
    Posts
    951
    +1
    75
    Rick, I have checked the throttle body and TPS as well, everything is cherry looking on this machine.
    One thing I was told I should do is to buy a new injector and swap them one by one, so after 4 rides I can rule out any injector issues...That is a pain but much cheaper than buying an ECU I guess.

  9. #9
    prostocker's Avatar
    Join Date
    Oct 2012
    Location
    FL
    Posts
    442
    +1
    17
    Had you checked the fuel pump or injectors to see if they are fine and does it pull any code when i does that ?

  10. #10

    Join Date
    Sep 2010
    Location
    Aliso Viejo
    Posts
    951
    +1
    75
    No code at all. In fact even invested in YDS 1.33 and could run these things at will. It works like a champ and everything within spec. Driving me nuts...
    Quote Originally Posted by prostocker View Post
    Had you checked the fuel pump or injectors to see if they are fine and does it pull any code when i does that ?

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 97 SLT 780 Spark Issue and Testing Questions
    By chriswelters in forum Polaris Open Discussion
    Replies: 5
    Last Post: 07-15-2016, 09:42 PM
  2. 2015 sea doo rxp-x ecu upgrade and speed questions
    By rxpx2015 in forum Sea Doo ECU Support
    Replies: 0
    Last Post: 12-04-2015, 07:51 PM
  3. VX110 mirror and remote question
    By god2dman in forum Yamaha PWC Performance (4-stroke)
    Replies: 4
    Last Post: 07-31-2013, 07:19 AM
  4. 2004 FX HO Buzzer issue and overheating question
    By CaptainReza in forum Yamaha PWC Performance (4-stroke)
    Replies: 4
    Last Post: 04-24-2011, 10:16 PM
  5. 2010 rxt x key issue and mod questions
    By macgyver in forum 4-Tec Performance
    Replies: 20
    Last Post: 06-23-2010, 05:43 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •