Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 31
  1. #1
    Kristian Keppel Waterholics's Avatar
    Join Date
    Apr 2010
    Location
    Trinidad & Tobago
    Posts
    1,405
    +1
    38

    Smoke coming through engine breather.

    So I was having this problem with my ski:

    http://www.greenhulk.net/forums/showthread.php?t=185180

    and I took it out last week with new plugs and was still having the same problem except this time the engine bay was filled with white smoke from the engine breather. It didn't pass 7500 RPM's at all. When I let off the throttle it just cut off and never started back. What could be causing this ?


  2. #2
    Gomer Pyle starter99's Avatar
    Join Date
    Sep 2009
    Location
    GA
    Posts
    642
    +1
    54
    DAMN look like it threw a code or something !!!!

  3. #3
    Kristian Keppel Waterholics's Avatar
    Join Date
    Apr 2010
    Location
    Trinidad & Tobago
    Posts
    1,405
    +1
    38
    Nope no codes thrown besides aux9/10 which is the throttle body which happens on a regular when the ski shuts off.

  4. #4

    Join Date
    Jul 2005
    Location
    Central North Carolina
    Posts
    3,847
    +1
    528
    Test engine compression first! Sounds like blow-by past the piston rings, Tommy Jordan


  5. #5
    ecpChris's Avatar
    Join Date
    Jul 2007
    Location
    ocean county nj
    Posts
    2,912
    +1
    427
    Quote Originally Posted by 2fast4u View Post
    Test engine compression first! Sounds like blow-by past the piston rings, Tommy Jordan
    +1. I bet one of your cylinders is dead. I saw this on a SHO with only 30 something hours. It started and ran until it warmed up then the cylinder locked up. The compression was only like 20 psi on that cylinder. The breather also smoked like a chimney.
    I don't want to scare you and not saying that is your problem but def throw a compression gauge on there.

  6. +1 by:


  7. #6
    gordon lasiter #328's Avatar
    Join Date
    Aug 2008
    Location
    katy, texas , United States
    Posts
    1,647
    +1
    28
    Quote Originally Posted by ecpChris View Post
    Quote Originally Posted by 2fast4u View Post
    Test engine compression first! Sounds like blow-by past the piston rings, Tommy Jordan
    +1. I bet one of your cylinders is dead. I saw this on a SHO with only 30 something hours. It started and ran until it warmed up then the cylinder locked up. The compression was only like 20 psi on that cylinder. The breather also smoked like a chimney.
    I don't want to scare you and not saying that is your problem but def throw a compression gauge on there.
    chances are the #2 or #3.

  8. +1 by:


  9. #7
    ecpChris's Avatar
    Join Date
    Jul 2007
    Location
    ocean county nj
    Posts
    2,912
    +1
    427
    Quote Originally Posted by gordon lasiter #328 View Post
    Quote Originally Posted by ecpChris View Post
    Quote Originally Posted by 2fast4u View Post
    Test engine compression first! Sounds like blow-by past the piston rings, Tommy Jordan
    +1. I bet one of your cylinders is dead. I saw this on a SHO with only 30 something hours. It started and ran until it warmed up then the cylinder locked up. The compression was only like 20 psi on that cylinder. The breather also smoked like a chimney.
    I don't want to scare you and not saying that is your problem but def throw a compression gauge on there.
    chances are the #2 or #3.
    Yes that motor I referenced lost #2

  10. #8
    Kristian Keppel Waterholics's Avatar
    Join Date
    Apr 2010
    Location
    Trinidad & Tobago
    Posts
    1,405
    +1
    38
    Thanks guys. I was kinda hoping in a way it was a piston. Now I can sleeve over and put in new pistons.

  11. #9
    Gus13letter's Avatar
    Join Date
    Apr 2008
    Location
    Tampa Bay, FL
    Posts
    8,136
    +1
    823
    Quote Originally Posted by Waterholics View Post
    Thanks guys. I was kinda hoping in a way it was a piston. Now I can sleeve over and put in new pistons.
    Ouch, unfortunately it is not that simple. If you are going to have it apart for a rebuild there is a lot more to it than just throwing sleeves and pistons in it. These arent 2 strokes... Last time I completed a rebuild it was new bearings, polish crank, balance complete rotating assembly, check block for straightness, deck head, lap the valves, file the rings for proper ring gap, etc.. Good luck and keep us posted on what you find.

  12. #10
    Kristian Keppel Waterholics's Avatar
    Join Date
    Apr 2010
    Location
    Trinidad & Tobago
    Posts
    1,405
    +1
    38
    Quote Originally Posted by Gus13letter View Post
    Quote Originally Posted by Waterholics View Post
    Thanks guys. I was kinda hoping in a way it was a piston. Now I can sleeve over and put in new pistons.
    Ouch, unfortunately it is not that simple. If you are going to have it apart for a rebuild there is a lot more to it than just throwing sleeves and pistons in it. These arent 2 strokes... Last time I completed a rebuild it was new bearings, polish crank, balance complete rotating assembly, check block for straightness, deck head, lap the valves, file the rings for proper ring gap, etc.. Good luck and keep us posted on what you find.
    I know I'm not happy about rebuilding it because most likely I won't have it running for summer, but atleast I have an excuse to forge out everything now and at least I don't have a hole in my block either. I will probably send my short block to RIVA to balance and polish crank and re-assemble with their pistons and rods.


Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Question about smoke coming out catch can breather?
    By skigolfnut in forum 4-Tec Performance
    Replies: 15
    Last Post: 03-14-2013, 12:51 PM
  2. Replies: 4
    Last Post: 03-07-2011, 12:00 PM
  3. smoke coming out of catch can
    By IBADTON in forum 4-Tec Performance
    Replies: 4
    Last Post: 05-30-2009, 10:14 AM
  4. engine breather hose
    By lardio in forum 4-Tec Performance
    Replies: 3
    Last Post: 04-05-2009, 05:46 PM
  5. Help smoke coming out of the front cover plug
    By XP537 in forum 2-Stroke Performance
    Replies: 10
    Last Post: 04-02-2009, 05:13 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •