Results 1 to 7 of 7
  1. #1

    Drive Shaft play

    How do I check the drive shaft play in my 95 750 SLT. When I grab it where it goes into the back of the motor it seams loose and moves back and forth about a inch. How do I tightn it up or is that the way it is suppose to be.
    Or how do I fix a problem

    Thanks guys

    Steve


  2. #2
    I'm addicted to Polaris PWC ghostinstallations's Avatar
    Join Date
    Aug 2011
    Location
    Rochester, New York
    Posts
    920
    +1
    28
    Welcome to The Hulk!

    That is not normal. There should be no play. Have you taken the pump apart? I would first check the condition of the parts and make sure the rubber bumpers are on the ends of the shaft. If they are missing, that would account for a decent chunk of play.

  3. #3
    Rasta Mon Condoms We Be Jammin!!!!! TxVirageTx's Avatar
    Join Date
    Aug 2006
    Posts
    5,775
    +1
    400
    there is play front to back.about an 1/8" is normal.suppose to be a rubber bumper on each end of the driveshaft

  4. #4
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,330
    +1
    31
    Welcome to the site.

    As they pointed out, a slight (1/8") back and forth is normal. The 2 rubber bumpers are only about 1/4" thick each. So if you're getting 1" of play, you got something seriously wrong there.

    Do a little research on how to remove your jet pump. Then have a good look at the jet pump installation, impeller, drive shaft, and the engine coupler. Something is not right.

  5. #5
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    Drive shaft play should be .100-.200 according to the Polaris manual. If you are missing the bumpers, you could be around 3/4" of play.

  6. #6
    Rasta Mon Condoms We Be Jammin!!!!! TxVirageTx's Avatar
    Join Date
    Aug 2006
    Posts
    5,775
    +1
    400
    check your pro1200 and see how much play you have with the bumpers

  7. #7
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    Quote Originally Posted by TxPro1200 View Post
    check your pro1200 and see how much play you have with the bumpers
    When I can get out from under the foot of snow on it I will.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Drive shaft play clarification
    By ptscon in forum 4-Tec Performance
    Replies: 3
    Last Post: 07-29-2015, 07:35 AM
  2. drive shaft play
    By imp0ster in forum 4-Tec Performance
    Replies: 34
    Last Post: 03-08-2014, 05:16 PM
  3. Drive Shaft Plug Replacement
    By 1FastTrespiper in forum Sea Doo Open Discussion
    Replies: 6
    Last Post: 07-17-2006, 10:47 PM
  4. how to remove rear drive shaft coupler
    By chuck in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 02-20-2006, 08:37 AM
  5. aftermarket drive shaft question...
    By dewsy in forum 4-Tec Performance
    Replies: 4
    Last Post: 01-26-2006, 07:47 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •