Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 34
  1. #1
    imp0ster's Avatar
    Join Date
    Dec 2011
    Location
    Palm Harbor, FL
    Posts
    5,038
    +1
    672

    SC thunking at certain RPMs?

    I can hear it loud and clear. It only does it while cruising around 5K RPMs. I can see the flex intake tube shift a bit when it happens. I could not see anything wrong with the shaft or assembly and the thing pulls harder than ever. It is not backfire.

    It this a symptom if wheel touchdown?


  2. #2
    Having Fun jp1300r's Avatar
    Join Date
    Sep 2005
    Location
    Florida
    Posts
    5,334
    +1
    261
    Almost sounds like a loose flywheel

  3. #3
    imp0ster's Avatar
    Join Date
    Dec 2011
    Location
    Palm Harbor, FL
    Posts
    5,038
    +1
    672
    Quote Originally Posted by jp1300r View Post
    Almost sounds like a loose flywheel
    It did this before my rebuild too. I replaced the bolts with 06+ and that biotch is on there. I also thought that before I tore it down due to the soft SS bolts that held it on from factory. Charger has 14hrs on it

  4. #4
    83.0 @ 8400 jhill19's Avatar
    Join Date
    Jul 2010
    Location
    Teays Valley, West Virginia
    Posts
    2,800
    +1
    81
    did you inspect the charger and check the slip?

  5. #5
    Boost-A-Holic's Avatar
    Join Date
    Jul 2012
    Location
    Dallas, Texas, United States
    Posts
    1,173
    +1
    94
    the bolts holding the SC in?

  6. #6
    imp0ster's Avatar
    Join Date
    Dec 2011
    Location
    Palm Harbor, FL
    Posts
    5,038
    +1
    672
    Quote Originally Posted by jhill19 View Post
    did you inspect the charger and check the slip?
    I did not take it apart when it was out but I put it on the dial and it broke loose at 10ft/lbs if I remember correct.

    Bolts are fine although I left the reverse one out.

  7. #7
    83.0 @ 8400 jhill19's Avatar
    Join Date
    Jul 2010
    Location
    Teays Valley, West Virginia
    Posts
    2,800
    +1
    81
    who built the charger? what bearings are in it?

  8. #8
    imp0ster's Avatar
    Join Date
    Dec 2011
    Location
    Palm Harbor, FL
    Posts
    5,038
    +1
    672
    Quote Originally Posted by jhill19 View Post
    who built the charger? what bearings are in it?
    Factory X-SC Bought it 1 maybe 1.5 years ago brand new

  9. #9
    shrabber's Avatar
    Join Date
    Apr 2008
    Location
    Jacksonville, FL
    Posts
    5,305
    +1
    376
    10ft pounds is fine I would at least check your Front and rear Nuts Tourqe settings for safety. Also spin the charger you can pretty much tell how the bearings are by feel to a point. You are getting close to a rebuild and Personally when you did your rebuild a sc rebuild at same time should have been included as well as a precaution. I can tell you what a supercharger can do to a engine and it is not pretty

  10. #10
    imp0ster's Avatar
    Join Date
    Dec 2011
    Location
    Palm Harbor, FL
    Posts
    5,038
    +1
    672
    Quote Originally Posted by shrabber View Post
    10ft pounds is fine I would at least check your Front and rear Nuts Tourqe settings for safety. Also spin the charger you can pretty much tell how the bearings are by feel to a point. You are getting close to a rebuild and Personally when you did your rebuild a sc rebuild at same time should have been included as well as a precaution. I can tell you what a supercharger can do to a engine and it is not pretty
    It spun freely and felt good when it was out although a small amount of corrosion was JUST scraping the case at a certain point. at 14hrs I shouldn't have to rebuild the SC. This would cost me over $600 a season just to ride. I will probably have to take it apart and see what's going on. Everything looked mint behind the PTO so if it ain't the SC it will be a head scratcher/beer drinker

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Bought a new to me 99 Genesis(carb) dies at certain rpms
    By PetroMan in forum Polaris Open Discussion
    Replies: 4
    Last Post: 09-16-2013, 08:32 PM
  2. XL1200 cavitation at high RPMs
    By jamie327 in forum Yamaha PWC Performance (2-stroke)
    Replies: 13
    Last Post: 03-19-2009, 07:17 AM
  3. Complete SC failure at 68 hours
    By Alex13 in forum 4-Tec Performance
    Replies: 19
    Last Post: 05-16-2007, 07:09 PM
  4. Riva Stage 3 Supercharger 11.8 PSI at 8200 RPM's
    By Green Hulk in forum 4-Tec Performance
    Replies: 16
    Last Post: 04-07-2007, 04:45 PM
  5. My stage 2 RXP, 75.5+mph at 7900 rpms, yahoo!
    By Vern in forum 4-Tec Performance
    Replies: 23
    Last Post: 06-21-2006, 11:10 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •