Results 1 to 7 of 7
  1. #1
    Polaris John's Avatar
    Join Date
    Jul 2012
    Location
    St.Petersburg Forida
    Posts
    269
    +1
    5

    Polaris Virage tx

    Does anyone have any idea I was riding wide open lost power then hard to start ran rough back to ramp. I do premix using amsoil im thinking of checking the compression first starting there. Thanks


  2. #2
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    Check your plug wires. I have one in the orange boot that likes to come off a plug all the time. Max RPM is about 5800 and it sounds like crap until I put it back on.

  3. #3
    Polaris John's Avatar
    Join Date
    Jul 2012
    Location
    St.Petersburg Forida
    Posts
    269
    +1
    5
    Quote Originally Posted by BryanP View Post
    Check your plug wires. I have one in the orange boot that likes to come off a plug all the time. Max RPM is about 5800 and it sounds like crap until I put it back on.
    Ill check the wires they may have gotten wet my flush hose adapter was leaking.Thanks

  4. #4
    I'm addicted to Polaris PWC ghostinstallations's Avatar
    Join Date
    Aug 2011
    Location
    Rochester, New York
    Posts
    920
    +1
    28
    I agree with Bryan. Check for the obvious, then do a compression check. Report back your results.
    Last edited by K447; 03-10-2013 at 08:32 PM.

  5. #5
    Polaris John's Avatar
    Join Date
    Jul 2012
    Location
    St.Petersburg Forida
    Posts
    269
    +1
    5
    Quote Originally Posted by ghostinstallations View Post
    I agree with Bryan. Check for the abvious, then do a compression check. Report back your results.
    I left the seat off all day today in the sun let it dry out checked the plug wires they did get wet.The water was pretty flat here on Saturday so I was getting good top end riding pretty hard.Shes running good now thanks to Bryan advice man I thought I lost a piston.I did order a new flush hose on ebay to replace the one that was spraying water in the hull.

  6. #6
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,587
    +1
    1,272
    Bryan had an engine that was spewing water across his engine from somewhere, affecting engine performance.

    Unless you are riding around with the seat off at high speed, it can be hard to detect small leaks that might be spraying water around the engine bay.

  7. #7
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    Quote Originally Posted by K447 View Post
    Bryan had an engine that was spewing water across his engine from somewhere, affecting engine performance.

    Unless you are riding around with the seat off at high speed, it can be hard to detect small leaks that might be spraying water around the engine bay.
    It was a pinched o ring on a head cover. It only leaked at speed, not at idle, so I never saw it when I checked it on the trailer. It pays to run with the seat off once in a while to check things out.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2000 polaris virage tx resonator melted.
    By gnose in forum Polaris Open Discussion
    Replies: 10
    Last Post: 08-25-2017, 12:02 PM
  2. Polaris Virage TX 1200 2001 no spark
    By balbes59 in forum Polaris Open Discussion
    Replies: 10
    Last Post: 06-28-2009, 11:34 AM
  3. 01 polaris Virage TX
    By wmurray in forum Polaris Skis
    Replies: 2
    Last Post: 07-23-2008, 12:23 PM
  4. New Toy 2001 Polaris Virage TX Injected
    By 800AMSOIL4U in forum Polaris Open Discussion
    Replies: 24
    Last Post: 04-19-2008, 11:47 AM
  5. 2000 Polaris Virage TX Help!
    By paperbirch in forum Polaris Open Discussion
    Replies: 1
    Last Post: 08-27-2007, 12:12 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •