Results 1 to 3 of 3
  1. #1
    Rex's Avatar
    Join Date
    Sep 2012
    Location
    Lake Mary, FL
    Posts
    180
    +1
    9

    0523 Fault Code, random shutdown, and smoke.

    Been trying to work the bugs out of my '11 RXTX aS for quite some time now. For reference, here is the link to my original post: http://www.greenhulk.net/forums/showthread.php?t=190934

    Originally it started as a low oil light which was a loose clamp on the drive shaft assembly. While I had the top deck lifted to resolve the clamp issue I installed a 4" intake and a catch can to give me some more room inside the engine compartment. Then has a leak that was caused by the "fixing plate" that the steering assembly mounts to. I took it out yesterday hoping everything was resolve and had two other issues arise.


    1. Riding along at about 3/4 throttle the ski just turned off. No warning lights, beeps, etc. It just turned off. Pulled the key, reseated it and it started back up fine. Only precursor to this was when I started it for the first time I got a fault code 0523. I looked through the sticky thread and didnt find that code. So I am not sure what it was. I turned it off and back on and the code was gone.


    2. There is light amounts of smoke coming from the port the catch can connects to. Here is a picture for reference:

    I noticed when I squeeze the catch can hose the smoke would "puff" out. I also notice the oil in the catch can was somewhat milky and almost green in color. Im assuming the milky-ness is water mixing with the oil. May be from a leaking intercooler? But why the smoke?


  2. #2
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,930
    +1
    1,407
    Fault P0523
    Descrption Oil Pressure sensor fault

  3. #3
    Rex's Avatar
    Join Date
    Sep 2012
    Location
    Lake Mary, FL
    Posts
    180
    +1
    9
    Thanks beerdart! Just got the response in the Trouble Code thread as well.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. getting strange fault codes, c2122 ibr and c2161 ibr
    By spacerrr in forum 4-Tec Performance
    Replies: 0
    Last Post: 12-17-2014, 07:14 PM
  2. Replies: 27
    Last Post: 08-02-2013, 10:54 AM
  3. Engine Fault Codes...fixing on own and clearing codes??
    By rvrkids in forum 4-Tec Performance
    Replies: 4
    Last Post: 07-01-2013, 04:17 PM
  4. 71 and 73 fault code
    By abie_lah in forum Yamaha ECU Support
    Replies: 2
    Last Post: 02-29-2012, 12:07 AM
  5. fault codes 42 and 45
    By thegasman34 in forum Honda How To & FAQs
    Replies: 2
    Last Post: 03-22-2009, 04:44 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •