Results 1 to 10 of 10
  1. #1

    Join Date
    Jul 2009
    Location
    UAE
    Posts
    180
    +1
    5

    Help please-seadoo Rxpx 2012

    Hi guys

    so the seasone started here in Dubai, started my ski every thing was normal cruised around for 5 min with no problems, then i increased my speed when i reach full throttel for 10 sec, the screen showes 2 lights check engin and oil light i took the key off and start the engine again it start in lip mode the rpm reaches 3000 max, went back home pulg my V-tech showed me the errors (20 p0524) (60 p2080), one is engin oil pressure i bought a new oil pressure sensor and same problem, went to the dealer they didnt find anything they just updated the IBR system, i emailed V-tech they send me new tune 8650 Aggressive but the same problem.

    any ideas that can help me please ?


  2. #2
    Kiwi spanner handler
    Join Date
    Dec 2007
    Location
    Christchurch NewZealand
    Posts
    579
    +1
    13
    check the oil filter hasn't collapsed in on itself, if it has check for intercooler leak

  3. #3

    Join Date
    Jul 2009
    Location
    UAE
    Posts
    180
    +1
    5
    will do thanks Jasonze

  4. #4

    Join Date
    Jul 2010
    Location
    Rock Hill, SC
    Posts
    101
    +1
    2
    Let us know what you find.

  5. #5

    Join Date
    Jul 2009
    Location
    UAE
    Posts
    180
    +1
    5
    problem solved

    modes:
    137 Etech
    Vtech 6500
    riva fule regulator
    air filter
    riva Exhaust
    speedfreaks impeller
    R&d cooling kit
    Riva Gen3

    top speed 80 miles.

    Waiting for the Motec now to see how it can give me more miles.
    Click image for larger version. 

Name:	20130313_171746.jpg 
Views:	192 
Size:	89.2 KB 
ID:	294843

  6. #6
    Olomana's Avatar
    Join Date
    Jan 2011
    Location
    Tahiti, French Polynesia
    Posts
    1,414
    +1
    76
    so? what was your issue?!
    Nice speed!

  7. #7
    ecpChris's Avatar
    Join Date
    Jul 2007
    Location
    ocean county nj
    Posts
    2,912
    +1
    427
    Quote Originally Posted by Olomana View Post
    so? what was your issue?!
    Nice speed!
    +1
    Looks like your check engine light is still on ?

  8. #8
    Rt-HemiBoY's Avatar
    Join Date
    Mar 2010
    Location
    HiAleAH-MiAMi--FL
    Posts
    1,315
    +1
    24
    You might need to upgrade injectors also...

  9. #9

    Join Date
    Jul 2009
    Location
    UAE
    Posts
    180
    +1
    5
    Quote Originally Posted by ecpChris View Post
    Quote Originally Posted by Olomana View Post
    so? what was your issue?!
    Nice speed!
    +1
    Looks like your check engine light is still on ?

    The issue was from the tune it need more fule, the check engine is from the exuhst sensor.

  10. #10

    Join Date
    Jul 2009
    Location
    UAE
    Posts
    180
    +1
    5
    Quote Originally Posted by Rt-HemiBoY View Post
    You might need to upgrade injectors also...
    I ordered the 1000 injectors with my motec

    Will test it when it arrives.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help please 08 rxpx - hull full of oil
    By Laxcrazy23 in forum 4-Tec Performance
    Replies: 10
    Last Post: 08-29-2016, 05:49 PM
  2. Seadoo Rxpx 2012 HELP!!!!
    By _Cato3d in forum 4-Tec Performance
    Replies: 0
    Last Post: 07-06-2016, 11:38 PM
  3. 2012 rxpx 260 need help please
    By C-kit in forum 4-Tec Performance
    Replies: 26
    Last Post: 07-11-2015, 11:34 PM
  4. Seadoo RXPX 2012 Help Needed!
    By Cato3D in forum 4-Tec Performance
    Replies: 2
    Last Post: 10-05-2012, 07:46 PM
  5. Little help please 1992 seadoo sp fuel line routes
    By fst4dr96 in forum 2-Stroke Performance
    Replies: 1
    Last Post: 08-04-2007, 06:41 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •