Page 1 of 2 1 2 LastLast
Results 1 to 10 of 19
  1. #1
    ILUVMYSKI's Avatar
    Join Date
    Mar 2013
    Location
    orlando fl
    Posts
    33
    +1
    1

    Only going 56mph on speedo?

    First off i'd like to say,this forum is awesome and has answered 90% of my questions ,except this: my 2008 ultra 250 x was just purchased last week.I was lucky enough that the person selling me the ski was part owner of the miami heat,down in boca raton fl, he purchased the ski's brand new in 2008,all service work and maintenance done by Riva motorsports in pompano beach fl.the ski only saw salt water as per he lived on an inlet.LONG STORY SHORT:I brought the ski back to my home town orlando fl, and put it on a fresh water lake.i had my wife use it first she dropped in the slow key, ran it for about ten mins,she brought it back to shore and it had a F1 warning on speedo, stating heat.. now i read in the manual that we had to flush out coolant after every salt water use????? i let the ski cool off for about ten mins, i slotted in the fast key and took off,no F1 warning no heat on speedo, she ran fine to me for the rest of the day went thru a full tank...except she only read 56 mph on speedo???? Im a crotch rocket guy and have owned nothing but 1000, and 1300 cc motorcycles.but this is my first ski. so i do need to know what should be done first to get it to at least a respectable 60-65.......IT FELT LIKE I WAS GOING THAT FAST BUT WAS ONLY MARKING 56MPH.... PLEASE ANY HELP WOULD BE GREATLY APPRECIATED >>>>>>>>>>>>>>GODSPEED TO ALL


  2. #2
    UltraKvz's Avatar
    Join Date
    Feb 2011
    Location
    Earth
    Posts
    378
    +1
    23
    The speedo is not very accurate but make sure your speedowheel is spinning freely. Spray some WD40 on and spin it with finger then test it again. Get a GPS to be sure!

  3. #3
    ILUVMYSKI's Avatar
    Join Date
    Mar 2013
    Location
    orlando fl
    Posts
    33
    +1
    1
    wiLL do,thank you for your advise,at 56mph it read 7-8000 rpm is that normal? will get gps asap. also about flushing the coolant from the ski after salt water use? or me running it on the fresh water lake after the salt water ?was that good enough than having to flush the system?

  4. #4
    SCSFAB's Avatar
    Join Date
    Jan 2007
    Location
    ANKENY ,IA
    Posts
    112
    +1
    2
    On the back of the ski is the speedometer sensor----the black box with a little paddle wheel . Loose up the two 5mm socket head screws, push down on the sensor and re tighten. Usually goes down from 1/16th to 1/8th of an inch. As everyone here tells you- jet ski speedometers are not very accurate- but this usually brings ultra speedometers closer to actual speed.

  5. #5
    OzarkYamMonster's Avatar
    Join Date
    Oct 2012
    Location
    Lake Of The Ozarks
    Posts
    2,152
    +1
    295
    As stated before, get the GPS, you can get an inexpensive one E-Trex 10, about $100.00, then make your runs ... that will give you a starting place. 50 -56, for a stock Ultra 250, is a little slow .... form what I know 60 - 62, is more like it. If you want 68 -70 you will have to do some mods, This is where this forum can really be of help ... a lot of knowledge will be made available to you for the asking! Good Luck

  6. #6
    ILUVMYSKI's Avatar
    Join Date
    Mar 2013
    Location
    orlando fl
    Posts
    33
    +1
    1
    Thank you, will also try this,taking out the ski again this weekend,will give you all an update.

  7. #7
    Banned User
    Join Date
    Jan 2009
    Location
    LA/oc
    Posts
    3,911
    +1
    129
    Quote Originally Posted by ILUVMYSKI View Post
    wiLL do,thank you for your advise,at 56mph it read 7-8000 rpm is that normal? will get gps asap. also about flushing the coolant from the ski after salt water use? or me running it on the fresh water lake after the salt water ?was that good enough than having to flush the system?
    Big difference between 7-8. 7500 is normal.

  8. #8
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    Yes riding it in fresh water after salt water use is best.
    It will flush it better than on the hose.

    Also don't forget to fog the s/c after EVERY DAY OF RIDING.
    The kaw s/c require more maintaining than other models.

  9. #9
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    Also have you done the pump upgrades?
    I've seen those pumps lock up at less than 20 hrs and ruin the motor.

  10. #10
    ILUVMYSKI's Avatar
    Join Date
    Mar 2013
    Location
    orlando fl
    Posts
    33
    +1
    1
    !!!! OK GUYS HERES THE UPDATE!!!! put the ski back out on the same lake, once again after it being in the water for only 10mins i go to pull off passed the no wake zone,and decide to take off like a bat out of hell.....and bump-bump. beep beep, the ski thru a heat temperature light on speedo. i was upset beyond belief. so i load the thing back up on trailer,i pull away from the dock. come to flippin find out, THE REASON THE SKI KEPT THROWING OUT THE HEAT INDICATOR ON SPEEDO WAS BECAUSE THE SKI KEEP SUCKING UP THE DAM LAKE WEED/SEAWEED LILLy PAD CRAPPY WATER GRASS!!! WHICH WASNT ALLOW THE WATER TO PASS THRU PUMP CAUSING HEAT SENSOR TO KEEP TRIPPING. (smfh) now my question is to all fellow member's on forum. should i replace the impeller for a new one? or is there some kind of mesh plate i can purchase for the bottom of the ski to keep that crap out of the pump/impeller etc..?? does the impeller act like a cheese grader/slasher? does it rip up that crap to shreds and blow it out the back??? I GREATLY THANK ALL OF YOU GUYS FOR YOUR INPUT AND HELP.. (pump upgrades?im assuming that hasnt been done,to the ski.but will check)

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Does the 2008 RXT X speedo only go up to 70MPH ??????
    By stevea99 in forum 4-Tec Performance
    Replies: 9
    Last Post: 07-10-2011, 06:22 PM
  2. Who`s going riding on the 4th?
    By Pale Rider in forum Sea Doo Open Discussion
    Replies: 8
    Last Post: 07-08-2006, 07:01 PM
  3. It's going out on Monday!!!
    By sbogi in forum Yamaha Open Discussion
    Replies: 13
    Last Post: 02-21-2006, 09:55 PM
  4. Whats the going price on a used 2003 gpr 1300?
    By blowbyu in forum Yamaha PWC Performance (2-stroke)
    Replies: 16
    Last Post: 01-21-2006, 12:19 AM
  5. The wedge will never go back on my ski!!!
    By Green Hulk in forum 4-Tec Performance
    Replies: 22
    Last Post: 11-06-2005, 06:21 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •