Results 1 to 8 of 8
  1. #1

    rpm too low !!! need to help !!!!

    hi guy !!!

    i have setup my new rxp-x 260 ski racing parts below :


    riva valve train
    torx racing stage 2 camshaft
    rotax racing intercooler
    et-68-140 superchager kit
    et water cooler cover
    riva intake mainfold upgader kit
    walbro 255 fuel pump
    riva water box
    thru hull exhaust
    riva open loop cooling kit
    skat-trak 3 bade impeller 14/19
    riva reduction nozzle size 83mm
    r&d auto trim nozzle
    riva ss wear ring
    r&d intake gate
    r&d trim plate
    riva 4 inch power filter kit
    riva catch can
    turbosmart fpr 800 (set static fuel pressure 58psi)
    vtech 1100cc injector
    vtech remap ecu rpm 9000
    riva sponson kit

    i setup finish ! go to test ski , rpm only 6700 , why rpm too low , i have check piston comporresor , superchager cluth slip , change to riva solas 4 bade 15/19 impeller and last change spark-plug , also same !!!! any guy can get me some advice ?????


  2. #2
    83.0 @ 8400 jhill19's Avatar
    Join Date
    Jul 2010
    Location
    Teays Valley, West Virginia
    Posts
    2,800
    +1
    81
    Quote Originally Posted by thomas loh View Post
    hi guy !!!

    i have setup my new rxp-x 260 ski racing parts below :


    riva valve train
    torx racing stage 2 camshaft
    rotax racing intercooler
    et-68-140 superchager kit
    et water cooler cover
    riva intake mainfold upgader kit
    walbro 255 fuel pump
    riva water box
    thru hull exhaust
    riva open loop cooling kit
    skat-trak 3 bade impeller 14/19
    riva reduction nozzle size 83mm
    r&d auto trim nozzle
    riva ss wear ring
    r&d intake gate
    r&d trim plate
    riva 4 inch power filter kit
    riva catch can
    turbosmart fpr 800 (set static fuel pressure 58psi)
    vtech 1100cc injector
    vtech remap ecu rpm 9000
    riva sponson kit

    i setup finish ! go to test ski , rpm only 6700 , why rpm too low , i have check piston comporresor , superchager cluth slip , change to riva solas 4 bade 15/19 impeller and last change spark-plug , also same !!!! any guy can get me some advice ?????
    sounds like a boost leak, check all clamps on the supercharger to intercooler and intercooler to throttle body and check intake manifold block off and clamp...

  3. #3
    jbombino's Avatar
    Join Date
    Jun 2007
    Location
    Hialeah, FL
    Posts
    636
    +1
    17
    Quote Originally Posted by thomas loh View Post
    hi guy !!!

    i have setup my new rxp-x 260 ski racing parts below :


    riva valve train
    torx racing stage 2 camshaft
    rotax racing intercooler
    et-68-140 superchager kit
    et water cooler cover
    riva intake mainfold upgader kit
    walbro 255 fuel pump
    riva water box
    thru hull exhaust
    riva open loop cooling kit
    skat-trak 3 bade impeller 14/19
    riva reduction nozzle size 83mm
    r&d auto trim nozzle
    riva ss wear ring
    r&d intake gate
    r&d trim plate
    riva 4 inch power filter kit
    riva catch can
    turbosmart fpr 800 (set static fuel pressure 58psi)
    vtech 1100cc injector
    vtech remap ecu rpm 9000
    riva sponson kit

    i setup finish ! go to test ski , rpm only 6700 , why rpm too low , i have check piston comporresor , superchager cluth slip , change to riva solas 4 bade 15/19 impeller and last change spark-plug , also same !!!! any guy can get me some advice ?????
    You got a boost gauge? If you do what is the vacuum reading at idle?

  4. #4
    i have check everything hose and clamp , everything is good !!! any advice ???

  5. #5
    Vern's Avatar
    Join Date
    May 2005
    Location
    Grand Haven, MI
    Posts
    3,594
    +1
    128
    Usually boost leak as mentioned already, or exhaust leak, or SC slip is low, these are the most common (that and old/bad gas or spark plugs). Try riding with the seat off (if exhaust leak, it will run good with seat off), if rpms don't come up, its not exhaust leak. How does it run? Idle good and at what rpm? Does it accelerate smooth, but just hit a wall at 6700 rpm?

    Is throttle blade able to open fully?

  6. #6

    Join Date
    Mar 2006
    Posts
    1,831
    +1
    119
    Quote Originally Posted by thomas loh View Post
    i have check everything hose and clamp , everything is good !!! any advice ???
    learning key?

  7. #7
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    cam timing?

  8. #8
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    Do a compression check, and post the results.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Spped/RPM too low?
    By rcapone in forum Yamaha PWC Performance (4-stroke)
    Replies: 81
    Last Post: 04-17-2013, 04:52 PM
  2. Replies: 0
    Last Post: 07-01-2012, 09:55 AM
  3. engine under vaccum AFR problem , need to help !!!!!!!!!!
    By thomas loh in forum 4-Tec Performance
    Replies: 3
    Last Post: 07-25-2011, 07:36 PM
  4. idea AFR problem need to help !!!!
    By thomas loh in forum 4-Tec Performance
    Replies: 2
    Last Post: 07-14-2011, 08:11 AM
  5. RPM's LOW...Need suggestions
    By BLACKSTI in forum 4-Tec Performance
    Replies: 4
    Last Post: 09-04-2007, 02:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •