Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
  1. #1
    papafever's Avatar
    Join Date
    Aug 2009
    Location
    miami
    Posts
    2,459
    +1
    3

    Big problem with rxpx 260

    Going crazy with this guys, wont go over 2000 rpm with a very rough idle cause runs way to rich, have check engine light on with code P0122 which is TPS sensor. Need help.


  2. #2
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    Bring it to the stealership for warranty work.

  3. #3
    papafever's Avatar
    Join Date
    Aug 2009
    Location
    miami
    Posts
    2,459
    +1
    3
    I just want to know if this happen to anyone and how they solve the problem , so when i do take it to the dealer the ski wont stay there 3 months for a bad TPS sensor.

  4. #4
    their fix should be to change the throttle body, most I have done also had a leaking intercooler

  5. #5
    blackvr's Avatar
    Join Date
    May 2007
    Location
    west palm beach
    Posts
    520
    +1
    70
    Quote Originally Posted by papafever View Post
    Going crazy with this guys, wont go over 2000 rpm with a very rough idle cause runs way to rich, have check engine light on with code P0122 which is TPS sensor. Need help.
    you need to get it hooked up to a buds and look at the tps reading while ski is idling. may be stuck at 100%. or you have a bad map sensor

  6. #6
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    If your dealership takes 3 months then find another dealership.

  7. #7
    Duke's Avatar
    Join Date
    Jul 2006
    Location
    Florida
    Posts
    10,004
    +1
    406
    Many have had issues with the TB. Try to find dealer that will work with you.

  8. #8
    papafever's Avatar
    Join Date
    Aug 2009
    Location
    miami
    Posts
    2,459
    +1
    3
    Quote Originally Posted by winterstick View Post
    their fix should be to change the throttle body, most I have done also had a leaking intercooler
    Quote Originally Posted by blackvr View Post
    Quote Originally Posted by papafever View Post
    Going crazy with this guys, wont go over 2000 rpm with a very rough idle cause runs way to rich, have check engine light on with code P0122 which is TPS sensor. Need help.
    you need to get it hooked up to a buds and look at the tps reading while ski is idling. may be stuck at 100%. or you have a bad map sensor
    Quote Originally Posted by wotxxxsd View Post
    If your dealership takes 3 months then find another dealership.
    Quote Originally Posted by Duke View Post
    Many have had issues with the TB. Try to find dealer that will work with you.
    Thanks for everything guys , i found a friend that knows a tech at a dealer close by thats gonna help me with everything.

  9. #9
    fh23rxp-x's Avatar
    Join Date
    May 2008
    Location
    Miami
    Posts
    462
    Yeah buddy just take it to the dealer and let the warranty take care of it. No need to stress it

  10. #10

    fault code p0122

    hi, i,m having the same problem and i cant find out what it is, can you let me know what was the problem you had, And what u had to do i dont have warranty no more I,m trying not to take it to a dealer

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. anyone having problems with ultra 260
    By the bizz in forum Kawasaki PWC Performance (4-stroke)
    Replies: 1
    Last Post: 09-01-2009, 01:48 PM
  2. Crazy Problem with RXPX display..Please Help?
    By RXTJeff in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 07-03-2008, 09:38 PM
  3. found big problem with my GP Pump shoe
    By Mr1300 in forum Yamaha PWC Performance (2-stroke)
    Replies: 15
    Last Post: 12-17-2007, 10:39 PM
  4. Well, I had a big problem with my Ski this Weekend...
    By LiquidDI in forum 4-Tec Performance
    Replies: 8
    Last Post: 05-20-2007, 10:00 PM
  5. OK big problem with the ski
    By mikegpr03 in forum Yamaha PWC Performance (2-stroke)
    Replies: 15
    Last Post: 03-26-2007, 06:31 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •