Results 1 to 3 of 3
  1. #1

    Rxp 215 cavitation

    Hey guys I'm new to the forum from Australia. I have a 2006 rxp 215 with riva washer solas prop 4" exhaust and a few more mods. Only recently noticed that when taking off at full rpm it hits revv limiter and cavitates then picks up and is fine. I'm not sure if the upgrades have caused this. I ride in fresh water and have never sucked up anything as its deep water front any help would be much appreciated.
    Cheers jacob


  2. #2
    Huh? Dyoung's Avatar
    Join Date
    May 2009
    Location
    Pt. Neches , Texas
    Posts
    1,021
    +1
    25
    check your wear ring....

  3. #3
    Thanks mate ill check it out

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 0
    Last Post: 08-07-2016, 07:32 PM
  2. RXP 215 cavitating, (new impeller/wear ring??)
    By nafem in forum 4-Tec Performance
    Replies: 25
    Last Post: 07-06-2015, 10:37 PM
  3. 2007 rxp 215 cavitation problem
    By Rhyschiasson1 in forum 4-Tec Performance
    Replies: 8
    Last Post: 04-27-2014, 10:52 AM
  4. 07 rxp 215 cavitation. Please help.
    By Yanko in forum 4-Tec Performance
    Replies: 6
    Last Post: 08-13-2012, 11:39 AM
  5. RXP 215 w/X Charger Cavitating
    By AirGigs in forum 4-Tec Performance
    Replies: 33
    Last Post: 05-02-2011, 05:06 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •