Page 1 of 2 1 2 LastLast
Results 1 to 10 of 19
  1. #1

    2005 RXP Running Rough

    HI To All,

    I have a 05" RXT that is running really rough. In fact she is only running on one cylinder as when I do a cylinder drop test while she is running, cyl 1 & 2 make (when I drop them) no difference in the running of the machine and when I drop 3, she shuts off immediately. She has good fire. The injectors are spraying good fuel and compression is as follows: cyl 1 132, cyl 2 129, cyl 3 121. Leak down test is around 20-24% on each cylinder. I have pulled valve cover and verified timing. My next step is to pull the PTO and check the trigger wheel and CPS. I am not getting any codes on the ECU which if I had a sensor or trigger wheel problem, I thought I would. Any ideas? Thanks.


  2. #2
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407
    Change your sparkplugs. Then swap coils for the known good cylinder.

  3. #3
    Sorry, i should have mentioned that I did put fresh plugs in and tried different coils.

  4. #4
    What fuel pressure are you getting at rail?

  5. #5
    Good fuel pressure. I think my problem is a bad motor. Did a wet compression test and found the following
    Cyl1 155psi
    Cyl2 198psi
    Cyl3 249psi and she stooped cranking as the motor was unable to build higher compression.
    These results indicate bad rings, pistons or bore.

  6. #6
    Banned User
    Join Date
    Aug 2011
    Posts
    5,049
    +1
    238
    Wow 198 and 249 psi

  7. #7
    Quote Originally Posted by thatdude596 View Post
    Wow 198 and 249 psi
    The thing is too that she was still climbing steadily on cyl 3, but the starter just was not able to spin the motor any higher.

  8. #8
    83.0 @ 8400 jhill19's Avatar
    Join Date
    Jul 2010
    Location
    Teays Valley, West Virginia
    Posts
    2,800
    +1
    81
    try another compression tester, that doesn't sound right. also do a leak down test

  9. +1 by:


  10. #9
    Quote Originally Posted by jhill19 View Post
    try another compression tester, that doesn't sound right. also do a leak down test
    I have done both. Tried another compression tester both of which are mighty vac, one analog and one digital-results were very similar. Leak down test was 24% on cyl 2 and 3.

  11. #10
    83.0 @ 8400 jhill19's Avatar
    Join Date
    Jul 2010
    Location
    Teays Valley, West Virginia
    Posts
    2,800
    +1
    81
    you should have significantly lower compression not higher if something was wrong

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. RXP runs rough after jumps
    By canuck in forum 4-Tec Performance
    Replies: 3
    Last Post: 09-09-2013, 08:58 AM
  2. Replies: 3
    Last Post: 05-15-2012, 11:09 AM
  3. 2005 rxp running lean
    By SLOWBOY31 in forum 4-Tec Performance
    Replies: 12
    Last Post: 04-20-2010, 09:44 AM
  4. 2005 RXP won't run but 55 mph
    By rockydood41 in forum 4-Tec Performance
    Replies: 21
    Last Post: 07-09-2009, 03:11 PM
  5. RXP-X Running Rough
    By MPower in forum 4-Tec Performance
    Replies: 9
    Last Post: 05-26-2008, 11:57 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •