Page 1 of 2 1 2 LastLast
Results 1 to 10 of 16
  1. #1

    2003 GTX 37 MPH Tops?

    Hey guys whats up...been reading here for a while and have gathered a lot of useful info, thanks for that.

    I seem to have a problem that you guys may have seen/been asked about before. My stock 2003 Seadoo GTX (non supercharged) is going about 35mph top on the seadoo speedo and it definitely feels like 35 and nothing over. In 2 uses the fastest its gone is 37, It will not go faster than that. I weigh 177. I recently purchased it and Ive taken it out 2 times and both times it ran the same. The more I read on here about speeds the more I realize that I dont think im getting the full speed out of mine. The only key I was given is a yellow one, Im pretty new to this stuff but I plan to stick around as I love it already. Does anyone know if theres something I can check or what the problem seems to be?

    Thanks in advance.


  2. #2
    The first thing I would do is change the plugs. How many rpm's are you turning at your top speed?

  3. #3
    Boost-A-Holic's Avatar
    Join Date
    Jul 2012
    Location
    Dallas, Texas, United States
    Posts
    1,173
    +1
    94
    i mean it sounds like wrong key but im pretty sure the yellow key is the fast key. lol lets see what everyone else has to say.

  4. #4
    I should have paid more attention to the RPM's but when riding I was thinking that the 35mph was normal. Then I got on here and read that it isnt
    When I did see the RPMS one time they were at the 7k range at WOT. I need to keep a close eye on that next time I ride it.
    As for the key, yeah I was thinking maybe the wrong key but before posting and asking that question i searched and seemed to find that the yellow key is indeed the unrestricted key.
    On a side note it started fine every time with no problems, planing out does take a while though.

    Additional Info:

    On 4/6/2012 the ski was serviced at the dealer, here is what was done as per the receipt at 57hrs on the reading. It has 61 hrs now.
    1 Filter Oil
    2 Semi Oil 4T
    3 Spark plug NGK
    1 Lube-Bombar
    1 YB30LB Battery

  5. #5
    surferd15's Avatar
    Join Date
    Jun 2007
    Location
    Fort Lauderdale, FL
    Posts
    1,142
    +1
    83
    Get under the ski and look at the intake grate area. Look at the impeller (prop) and wear ring (plastic ring around the impeller)check for damages, cracks, chunks missing, prop dings etc.

  6. #6
    Booner76's Avatar
    Join Date
    Oct 2009
    Location
    Stirling ,Ont.
    Posts
    222
    +1
    5
    Quote Originally Posted by surferd15 View Post
    Get under the ski and look at the intake grate area. Look at the impeller (prop) and wear ring (plastic ring around the impeller)check for damages, cracks, chunks missing, prop dings etc.
    +1.... sounds like that's the issue....You should be in the high 50's MPH.

  7. #7
    CJ's gpr's Avatar
    Join Date
    Aug 2012
    Location
    Long Island
    Posts
    685
    +1
    34
    did you test drive it before you purchased it? it could run and sound great sitting in the driveway and then when you put a load on it, it could run totally different. and I agree with surferd15, sounds like you have rock damage to your prop. even the slightest knicks could cause big problems

  8. #8

    Join Date
    Aug 2008
    Location
    redlake ontario canada
    Posts
    416
    +1
    3
    check your oil and see if it is between the two bends.

  9. #9
    Going out to check those things right now.
    Thanks for the advice so far.
    I didnt get to test drive it before buying, I was looking for a project ski and seems that I found one, at what I paid for it I dont think i can complain.

    Edit:
    Ouch, just went out and took some pictures. looks like the impeller? is bent and cut. going to try the spark plug thing first to see if there's any improvement.
    is the impeller all one piece, any estimated quotes on replacing it?






    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	1.jpg 
Views:	35 
Size:	111.0 KB 
ID:	295423   Click image for larger version. 

Name:	2.jpg 
Views:	37 
Size:	104.3 KB 
ID:	295424   Click image for larger version. 

Name:	3.jpg 
Views:	38 
Size:	77.1 KB 
ID:	295425   Click image for larger version. 

Name:	4.jpg 
Views:	46 
Size:	62.9 KB 
ID:	295426  
    Last edited by hurley994; 03-20-2013 at 11:43 PM.

  10. #10
    surferd15's Avatar
    Join Date
    Jun 2007
    Location
    Fort Lauderdale, FL
    Posts
    1,142
    +1
    83
    Ouch, spark plugs wont change much. The front of your pump veins might be damaged too (cant see since prop is in the way)at least you need impeller and wear ring.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2011 VX Cruiser 37 MPH top speed
    By tobyyost in forum Yamaha PWC Performance (4-stroke)
    Replies: 43
    Last Post: 06-30-2016, 06:06 AM
  2. 2003 GTX SC first time out in 2 weeks and it will only go 40 mph
    By gregsgp1200 in forum 4-Tec Performance
    Replies: 12
    Last Post: 08-25-2011, 11:29 PM
  3. 04 gtx 30 mph top speed
    By joey0909 in forum Sea Doo Open Discussion
    Replies: 15
    Last Post: 07-04-2011, 01:31 PM
  4. Replies: 0
    Last Post: 05-11-2009, 01:29 AM
  5. adding external intercooler to 2003 gtx sc motor
    By rapidacceleration in forum 4-Tec Performance
    Replies: 12
    Last Post: 05-12-2005, 08:17 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •