Results 1 to 3 of 3

Thread: 95 seadoo 650

  1. #1

    95 seadoo 650

    I have a 95 seadoo 650, recently realised there is a snapped cable that connects to the accelerator cable. Sometimes when driving it misses really bad and doesn't get over 1500 rpm and then other times is fine. Just wondering it this cable might let the oil into the fuel and may be the cause. Any help would be good. Thanks


  2. #2
    Tiny's Avatar
    Join Date
    Sep 2006
    Location
    The Atl
    Posts
    3,561
    +1
    578
    Can you get a picture of the cable?? Might be the oil pump cable???

  3. #3
    flyin' the friendly skies airbornexp's Avatar
    Join Date
    Aug 2007
    Location
    Mahomet, Il. USA
    Posts
    6,004
    +1
    163
    Sounds like your oil is full on if the cable is snapped. Also when was the last time the fuel system was cleaned and replaced?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. '95 sl 650 cdi elec box replacement
    By john73 in forum Polaris Open Discussion
    Replies: 5
    Last Post: 09-24-2007, 07:07 PM
  2. '95 seadoo xp vts
    By jetcar123 in forum 2-Stroke Performance
    Replies: 6
    Last Post: 08-15-2007, 11:28 AM
  3. 95 sportster 650 need pto and drive shaft
    By friday280 in forum Sea Doo Sport Boats
    Replies: 0
    Last Post: 08-10-2007, 06:35 AM
  4. SL650 vs. Seadoo 650
    By kmartin173 in forum Polaris PWC Performance
    Replies: 10
    Last Post: 07-02-2007, 11:38 PM
  5. 95 seadoo tuning and damn beeping noise driving me nuts
    By gvnitup in forum 2-Stroke Performance
    Replies: 1
    Last Post: 04-22-2007, 07:36 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •