Results 1 to 3 of 3

Thread: 95 seadoo 650

  1. #1

    95 seadoo 650

    I have a 95 seadoo 650, recently realised there is a snapped cable that connects to the accelerator cable. Sometimes when driving it misses really bad and doesn't get over 1500 rpm and then other times is fine. Just wondering it this cable might let the oil into the fuel and may be the cause. Any help would be good. Thanks

  2. #2
    Tiny's Avatar
    Join Date
    Sep 2006
    The Atl
    Can you get a picture of the cable?? Might be the oil pump cable???

  3. #3
    flyin' the friendly skies airbornexp's Avatar
    Join Date
    Aug 2007
    Mahomet, Il. USA
    Sounds like your oil is full on if the cable is snapped. Also when was the last time the fuel system was cleaned and replaced?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help 1995 SeaDoo 650 GTX Won't Start
    By JohnCiccarelli in forum Sea Doo Open Discussion
    Replies: 11
    Last Post: 11-30-2011, 01:48 PM
  2. WTB seadoo 650 engine
    By fordpower in forum Sea Doo Classifieds
    Replies: 2
    Last Post: 04-05-2010, 10:39 PM
  3. SeaDoo 650 crankshaft assy.
    By nikko mercado in forum 2-Stroke Performance
    Replies: 4
    Last Post: 11-15-2009, 08:35 PM
  4. 94 seadoo xp 650
    By johnson7454 in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 09-02-2008, 06:37 PM
  5. SL650 vs. Seadoo 650
    By kmartin173 in forum Polaris PWC Performance
    Replies: 10
    Last Post: 07-02-2007, 11:38 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts