Results 1 to 8 of 8
  1. #1

    2003 4 tec supercharged top speed issues

    Hello all, Now I am 56mph at 6700 rpm after installing new drive shaft, sbt metal pump, solas impeller factory pitch with new wear ring. Ski jump out of hole with great mid range. The only thing that concerned me was the impeller seemed to be a bit tight. Before the pump work I was getting 50mph at 7900 rpm? Could the pump be limiting the top end?


  2. #2
    imp0ster's Avatar
    Join Date
    Dec 2011
    Location
    Palm Harbor, FL
    Posts
    5,038
    +1
    672
    I'm not sure how you lost 1200rpm and gained 6mph while keeping the same impeller, unless your other prop was complete junk. Is this a GTX? How are you measuring speed? Is there a supercharger? Have you changed plugs? Are you 100% sure the pump is on right? BTW if the motor has never been moved you can bet your ass the alignment is off and the mounts are crap.

  3. #3
    GOO$E Mongoose2's Avatar
    Join Date
    Jan 2006
    Location
    LKN, NC
    Posts
    442
    +1
    1
    Should top out at 7500+. What pitch Solas? 12/20.

  4. #4
    Yes it is 12/20 pitch. History on the ski, I went to service the ski for a customer and a s/c rebuild.
    Once charger was done and service was complete ski would run 7900rpm @50 mph.

    Pulled pump and it was horrid. Plastic pump was warped shaft was stripped impeller teeth were worn.

    I replaced the drive shaft, carbon ring, bellow, pump, impeller (solas 12/20) and now I get 56 mph @ 6600 rpm.

    I bet that this engine is worn ass out. I am heading back to check compression on it later today.

  5. #5
    GOO$E Mongoose2's Avatar
    Join Date
    Jan 2006
    Location
    LKN, NC
    Posts
    442
    +1
    1
    Top speed is 60-couple at 7500 typically. I'd say the prop is too big

  6. #6
    Sigmarxt's Avatar
    Join Date
    Mar 2012
    Location
    Greece
    Posts
    396
    +1
    43
    S/C ok? 6600rpm and 55mph could be a no working SC ski ( exactly the numbers I had when my SC went off). Maybe extremely bad luck..once you fixed the driveline ( where you had correct rpms and no speed) , the SC failed.. Something similar happened to me. I tested my ski before buying and everything was OK . The next day went for a ride, fired it up and the ski could not pass 6500rpms. The washers must have failed seconds before I stopped the ski when I tested it or just after I started it the next day..! So, 7900 rpms- 50 mph= good sc bad driveline......6600 rpms- 56 mph= bad sc good driveline..just a hypothesis..
    Last edited by Sigmarxt; 03-24-2013 at 03:11 PM.

  7. #7
    Quote Originally Posted by Sigmarxt View Post
    S/C ok? 6600rpm and 55mph could be a no working SC ski ( exactly the numbers I had when my SC went off). Maybe extremely bad luck..once you fixed the driveline ( where you had correct rpms and no speed) , the SC failed.. Something similar happened to me. I tested my ski before buying and everything was OK . The next day went for a ride, fired it up and the ski could not pass 6500rpms. The washers must have failed seconds before I stopped the ski when I tested it or just after I started it the next day..! So, 7900 rpms- 50 mph= good sc bad driveline......6600 rpms- 56 mph= bad sc good driveline..just a hypothesis..
    Compression test came out 115/115/120, Charger washers where all still together, So I pulled charger and ging to check the slip on it tomorrow. What is a good slip number on a 2003 sc 185? I had it at 12 fps. Thanks guys

  8. #8
    brendanm's Avatar
    Join Date
    Jan 2013
    Location
    Gold Coast, Australia
    Posts
    738
    +1
    149
    My gtx sc pulls 63 @ 7600, sounds like you have the power but prop is too steep? Do you have the old prop to try?

  9. +1 by:


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. VXR Top speed issue?
    By Wayne9499 in forum Yamaha PWC Performance (4-stroke)
    Replies: 21
    Last Post: 04-02-2014, 03:28 PM
  2. WTB 2003-2003 4-Tec Supercharged Shortblock
    By Ski Hacks MG in forum Sea Doo 4Tec Skis
    Replies: 2
    Last Post: 04-29-2013, 12:13 PM
  3. Bought 08 ultra 250x, RPM's ok but low top speed issue
    By cratica in forum Kawasaki PWC Performance (4-stroke)
    Replies: 8
    Last Post: 05-13-2012, 02:28 PM
  4. 2003 4-tec GTX half speed/power
    By leejax01 in forum 4-Tec Performance
    Replies: 14
    Last Post: 04-01-2012, 09:13 PM
  5. 2001 Virage top speed issues
    By cgrooms in forum Polaris PWC Performance
    Replies: 9
    Last Post: 07-12-2011, 10:26 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •