Page 1 of 2 1 2 LastLast
Results 1 to 10 of 18
  1. #1
    yamahamiamiski's Avatar
    Join Date
    Aug 2012
    Location
    Florida
    Posts
    571
    +1
    48

    Question for those running E1 wheel and R3 reflash

    This weekend hopefully I will be tuning my ski with its new setup. I have E1 wheel and r3 reflash with stock injectors and walbro fuel pump...for those of you running an e1/r3/stock injectors setup, where do you have your fuel pressure?


  2. #2
    hdlefler's Avatar
    Join Date
    Aug 2010
    Location
    Wesley Chapel, Fl
    Posts
    911
    +1
    100
    Quote Originally Posted by yamahamiamiski View Post
    This weekend hopefully I will be tuning my ski with its new setup. I have E1 wheel and r3 reflash with stock injectors and walbro fuel pump...for those of you running an e1/r3/stock injectors setup, where do you have your fuel pressure?
    I believe your duty cycle will be maxed out if you turn more than 8200 with that wheel and stock injectors especially in the colder months. I believe it was Desperado that did a test with different wheels with stock injectors and anything over 8200 witrh a low boost or bigger would max out the duty cycle of the stock injector.Do a search. I believe Gus was running lean with stock injectors but he had a fuel pump issue as well. I run the STI pink injectors and they are perfect. Gus runs them as well and he has he E1 R3 combo turning 8600-8700. No problems.

  3. #3
    yamahamiamiski's Avatar
    Join Date
    Aug 2012
    Location
    Florida
    Posts
    571
    +1
    48
    Quote Originally Posted by hdlefler View Post
    Quote Originally Posted by yamahamiamiski View Post
    This weekend hopefully I will be tuning my ski with its new setup. I have E1 wheel and r3 reflash with stock injectors and walbro fuel pump...for those of you running an e1/r3/stock injectors setup, where do you have your fuel pressure?
    I believe your duty cycle will be maxed out if you turn more than 8200 with that wheel and stock injectors especially in the colder months. I believe it was Desperado that did a test with different wheels with stock injectors and anything over 8200 witrh a low boost or bigger would max out the duty cycle of the stock injector.Do a search. I believe Gus was running lean with stock injectors but he had a fuel pump issue as well. I run the STI pink injectors and they are perfect. Gus runs them as well and he has he E1 R3 combo turning 8600-8700. No problems.
    I was running the E1 with stock injectors with the Athena. I just had to upgrade the fuel pump. Since the Athena tune demands WAY more fuel than the R3 tune, I think my Walbro fuel pump with stock injectors should be fine. I just would like to see what others with this combo did. If for whatever strange reason I stay lean, then I will switch to the pinks.

  4. #4
    Gus13letter's Avatar
    Join Date
    Apr 2008
    Location
    Tampa Bay, FL
    Posts
    8,136
    +1
    822
    With my R3 and E1 I was running stock injectors with RRFPR set to I beleive 43-44psi at idle with boost line connected, but also had a Powershot which was set to factory settings. I basically used the Powershot to add fuel up top. I was able to run 12.5 at 8700 RPM. Without the Powershot I was at 13.5 AFR at 8700 RPM.

  5. #5
    hdlefler's Avatar
    Join Date
    Aug 2010
    Location
    Wesley Chapel, Fl
    Posts
    911
    +1
    100
    Quote Originally Posted by Gus13letter View Post
    With my R3 and E1 I was running stock injectors with RRFPR set to I beleive 43-44psi at idle with boost line connected, but also had a Powershot which was set to factory settings. I basically used the Powershot to add fuel up top. I was able to run 12.5 at 8700 RPM. Without the Powershot I was at 13.5 AFR at 8700 RPM.
    So basically you were lean without the powershot.

  6. #6
    yamahamiamiski's Avatar
    Join Date
    Aug 2012
    Location
    Florida
    Posts
    571
    +1
    48
    Lean, but with the stock fuel pump. Same thing happened to me with Athena, that's why I had to go with the Walbro.

  7. #7
    hdlefler's Avatar
    Join Date
    Aug 2010
    Location
    Wesley Chapel, Fl
    Posts
    911
    +1
    100
    Quote Originally Posted by yamahamiamiski View Post
    Quote Originally Posted by hdlefler View Post
    Quote Originally Posted by yamahamiamiski View Post
    This weekend hopefully I will be tuning my ski with its new setup. I have E1 wheel and r3 reflash with stock injectors and walbro fuel pump...for those of you running an e1/r3/stock injectors setup, where do you have your fuel pressure?
    I believe your duty cycle will be maxed out if you turn more than 8200 with that wheel and stock injectors especially in the colder months. I believe it was Desperado that did a test with different wheels with stock injectors and anything over 8200 witrh a low boost or bigger would max out the duty cycle of the stock injector.Do a search. I believe Gus was running lean with stock injectors but he had a fuel pump issue as well. I run the STI pink injectors and they are perfect. Gus runs them as well and he has he E1 R3 combo turning 8600-8700. No problems.
    I was running the E1 with stock injectors with the Athena. I just had to upgrade the fuel pump. Since the Athena tune demands WAY more fuel than the R3 tune, I think my Walbro fuel pump with stock injectors should be fine. I just would like to see what others with this combo did. If for whatever strange reason I stay lean, then I will switch to the pinks.

    I have heard of some skis that are fine with stock injectors with E1 wheel and some can not and run lean. The guys down here seem to run pretty good afrs with aftermarket injectors and wheels 16+ boost. I wonder if its a Florida thing or something. Let us know your afr's.

  8. #8
    yamahamiamiski's Avatar
    Join Date
    Aug 2012
    Location
    Florida
    Posts
    571
    +1
    48
    When I was tuning the Athena the tune called for it to be set at 65 static. Static didn't work, but I ended up setting it at 65 with rising rate and at 80 degrees the AFR was 11.9-12.1. Like I said ....I will try what I got first, but if all else fails...I'll get the pinks.

  9. #9
    badjoka's Avatar
    Join Date
    Jun 2009
    Location
    Fairfield, CT
    Posts
    1,387
    +1
    122
    Quote Originally Posted by hdlefler View Post
    Quote Originally Posted by Gus13letter View Post
    With my R3 and E1 I was running stock injectors with RRFPR set to I beleive 43-44psi at idle with boost line connected, but also had a Powershot which was set to factory settings. I basically used the Powershot to add fuel up top. I was able to run 12.5 at 8700 RPM. Without the Powershot I was at 13.5 AFR at 8700 RPM.
    So basically you were lean without the powershot.
    What a coincidence - I have a powershot for sale (super shameless plug!)

  10. #10
    yamahamiamiski's Avatar
    Join Date
    Aug 2012
    Location
    Florida
    Posts
    571
    +1
    48
    Quote Originally Posted by badjoka View Post
    Quote Originally Posted by hdlefler View Post
    Quote Originally Posted by Gus13letter View Post
    With my R3 and E1 I was running stock injectors with RRFPR set to I beleive 43-44psi at idle with boost line connected, but also had a Powershot which was set to factory settings. I basically used the Powershot to add fuel up top. I was able to run 12.5 at 8700 RPM. Without the Powershot I was at 13.5 AFR at 8700 RPM.
    So basically you were lean without the powershot.
    What a coincidence - I have a powershot for sale (super shameless plug!)
    no thanks.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Question For those with the 2014+ ET 19 lb wheel
    By FallinOffHurts in forum Yamaha PWC Performance (4-stroke)
    Replies: 0
    Last Post: 03-09-2015, 03:16 PM
  2. question for those running without tabs
    By whiteyz in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 07-21-2008, 10:32 AM
  3. 3 questions for those in the know...
    By VaRedneck in forum 4-Tec Performance
    Replies: 3
    Last Post: 04-04-2006, 09:45 PM
  4. Question for those with Piggy Back Fuel Controller
    By 1 FAST VE in forum 4-Tec Performance
    Replies: 9
    Last Post: 03-19-2006, 08:48 PM
  5. question for those with a professionally ported head
    By GTXX in forum 4-Tec Performance
    Replies: 7
    Last Post: 03-06-2006, 11:38 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •