Results 1 to 2 of 2
  1. #1

    2006 r-12x Oil Sensor Problem?

    I just bought a used 2006 r-12x with 52 hours on it. Guy said he had 2 rides on the oil change and it was good to go. Took it out and it ran fine in the lake for about 30 minutes but when i got back into the river to smoother water i had problems.

    I was able to go wide open (about 60mph) in the river and at top speed a loud beeping sound comes on, the motor cuts back, and the oil light starts flashing. i double checked the oil and it was fine.

    I started it back up and it ran fine around 40mph but as soon as i started going wide open again it did the same thing. Has anyone had this problem? what should I do?

  2. #2
    Changed both sensors and its working fine.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2006 GP1300R oil consumption problem???
    By mikesumer in forum Yamaha Open Discussion
    Replies: 2
    Last Post: 07-19-2008, 01:09 AM
  2. oil change problems...
    By lextoy in forum Sea Doo Open Discussion
    Replies: 12
    Last Post: 10-25-2007, 03:04 AM
  3. HELP wite my f12x -02 knock sensor problem
    By audirs2 in forum Honda Open Discussion
    Replies: 4
    Last Post: 08-17-2007, 07:45 PM
  4. oil sensor #2
    By mjet in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 12-12-2006, 08:00 PM
  5. NEED HELP! with oil pressure problem!...
    By Pale Rider in forum Sea Doo Open Discussion
    Replies: 55
    Last Post: 11-21-2006, 05:46 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts