Results 1 to 7 of 7
  1. #1

    ULTRA 150 frozen motor HELP

    I have a kawasaki ultra 150 that sat in the garage for a coule of years now the engine is frozen. I took the spark plugs off and put some mystery oil in the cylinders but did nothing. The cylinders are sideways so i dont think the oil is getting to the whole piston. Do i flip the ski so the cylinders are straight??? Also took the jet pump out. Trid turning the motor with a wrench but nothing thanks


  2. #2
    Pull the engine. It needs to come apart

  3. #3
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    5,011
    +1
    283
    Welcome aboard, Ultra150miami!

    Are you sure it's the engine and not the pump that's frozen? The pumps will often corrode during storage and the corrosion will push the pump liner against the impeller. Try sliding the engine forward to disengage the coupling and see if the engine turns over.

    If it's still stuck, the engine is probably toast. This usually occurs if the engine is submerged and not properly dried out.

  4. #4
    jet pump is out no sign of turning

  5. #5
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    5,011
    +1
    283
    MMO is good stuff, but it won't help that. Crank bearings are probably rusted solid. As turboman said, tear it down.

  6. #6
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    6,523
    +1
    1,269
    what everybody else said..you might get lucky and have one piston rusted in place from evaporation from the water box, but it's gonna get ugly any way you look at it.

    fortunate that the engine didn't break free as it would have likely grenade as soon as it started up. two strokes are like pocket watches..they get dirty..they turn to mush unless cleaned up correctly.

  7. #7
    Seakid's Avatar
    Join Date
    Jun 2012
    Location
    East Texas
    Posts
    442
    +1
    9
    Can't tell unless u see inside so take engine apart and clean it up... Could be simple fix.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Ultra 150 tach install help
    By stang4u2nv in forum Kawasaki PWC Performance (2-stroke)
    Replies: 12
    Last Post: 10-28-2010, 12:43 PM
  2. Ultra 150 pump removal help
    By kaboom3757 in forum Kawasaki How To & FAQs
    Replies: 2
    Last Post: 07-06-2010, 08:37 PM
  3. WTB Flywheel tool for Ultra 150 1200 motor
    By TDSRacing in forum Kawasaki Classifieds
    Replies: 0
    Last Post: 10-22-2009, 04:21 PM
  4. ultra 150 handiling ??? please help
    By racer28 in forum Kawasaki PWC Performance (2-stroke)
    Replies: 6
    Last Post: 08-25-2008, 09:15 AM
  5. Ultra 150 voltage regulator Help!!!
    By btldigger in forum Kawasaki Open Discussion
    Replies: 10
    Last Post: 05-06-2008, 11:03 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •