Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 28
  1. #1

    Traction Control

    Hey guys, I have another ?????
    so the ski (2007 ultra LX) feels like it has a traction control when it's pegged wide open in a turn,
    Or hitting rough water... Anyone know anything about that? OOr how to remove it so I can be in control instead of the computer


  2. #2
    pgh300x's Avatar
    Join Date
    Oct 2011
    Location
    Pittsburgh Pa
    Posts
    114
    +1
    3
    I'm no expert, and sure someone else will chime in but...

    Are you talking about hitting the rev limiter when you are unhooked? If you can't keep the the intake grate in the water you are gonna lose hookup and speed.

    Thats why the trim on the 300 electric trim is nice, you can trim down and keep the ski hooked up in the rough stuff


    Otherwise does the ski run ok in the calm water?

  3. #3
    No it does NOT rev out the best way I can describe it is if I am idling and turn hard left (or right) and go full throttle, it will only his lets say 4500 rpms, then when I straighten out it takes off, almost like a traction control.... But it does not redline or anything

  4. #4
    pgh300x's Avatar
    Join Date
    Oct 2011
    Location
    Pittsburgh Pa
    Posts
    114
    +1
    3
    A guy I used to ride with had an STX 15F and had similiar issue (same 160hp NA motor) and his fuel pump end up going bad.

    Anyway, if it was me I would check plugs and inspect the pump and instake grate in the case you sucked something up.

    That my best guess, give it some time and I'm sure the vets on the forum will have better ideas

    Just curious...where you ride?

  5. #5
    I live on the Rogue River, Southern Oregon.. This will be my first summer having it up here but it should be pretty wild being able to ride 80 miles up river.

  6. #6
    Im waiting on the pressure sensor and I have new plugs for it... I will give it another shot next week when the sensor gets in.... And given the weather is a little nicer so I dont mind getting wet, I have only given it a few test runs fully clothed shoes jacket and all. But last time we had it at the lake (4 years ago) it was doing this and I seem to remember it hitting choppy water and it would not go full rpms till it smoothed out.... Must be something with the engine, ive talked to a few people about this and they have no clue what im talking about

  7. #7
    brisyl's Avatar
    Join Date
    Feb 2009
    Location
    New Brunswick, Canada
    Posts
    681
    +1
    59
    there is no such thing like a traction control on your ski, does it rev at max RPM in strait line?

  8. #8
    Banned User
    Join Date
    Jan 2009
    Location
    LA/oc
    Posts
    3,911
    +1
    129
    Check your throttle cable routing and make sure at full stop the throttle butter fly remains fully open.

  9. #9
    Quote Originally Posted by brisyl View Post
    there is no such thing like a traction control on your ski, does it rev at max RPM in strait line?
    yep 7600 give or take 50...

    once I get a chance to get out there with my shorts on ill give it a go again and see if it still does it... my surfer buddy (previous owner) said his friend had one that did the same thing and he disconnected it???

    But maybe there was a fouled plug or something that was making it do it....

  10. #10
    brisyl's Avatar
    Join Date
    Feb 2009
    Location
    New Brunswick, Canada
    Posts
    681
    +1
    59
    Like i said, you don't have anything to disconnect, first check you throttle cable and make sure it's adjusted
    Quote Originally Posted by cvbwaller View Post
    Quote Originally Posted by brisyl View Post
    there is no such thing like a traction control on your ski, does it rev at max RPM in strait line?
    yep 7600 give or take 50...

    once I get a chance to get out there with my shorts on ill give it a go again and see if it still does it... my surfer buddy (previous owner) said his friend had one that did the same thing and he disconnected it???

    But maybe there was a fouled plug or something that was making it do it....

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Traction control!
    By 2013_fzs_will in forum Yamaha PWC Performance (4-stroke)
    Replies: 33
    Last Post: 08-07-2013, 12:52 AM
  2. Traction Control??
    By cvbwaller in forum Yamaha PWC Performance (4-stroke)
    Replies: 0
    Last Post: 03-29-2013, 06:51 PM
  3. traction control feature
    By rossnemo in forum Yamaha ECU Support
    Replies: 12
    Last Post: 12-02-2010, 04:55 PM
  4. Traction Control
    By ercBOOSTED in forum Yamaha ECU Support
    Replies: 4
    Last Post: 10-20-2010, 01:18 AM
  5. what is traction control and disable angle sensor
    By dav_dman in forum Yamaha PWC Performance (2-stroke)
    Replies: 5
    Last Post: 08-28-2007, 06:43 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •