Results 1 to 4 of 4
  1. #1
    demian5's Avatar
    Join Date
    May 2012
    Location
    Lake Forest, CA
    Posts
    152
    +1
    4

    Has anyone ever repaired a trim gauge itself?

    I have a 95 xp800 and the signals going to the gauge are good and change with the trim position but the gauge doesn't work. Has anyone torn a gauge apart to repair it before?


  2. #2
    Seakid's Avatar
    Join Date
    Jun 2012
    Location
    East Texas
    Posts
    442
    +1
    9
    Would like to know too. I had two that have some moist inside and really itching me to trying to take off to wipe it off.

  3. #3
    20 feet Boy's Avatar
    Join Date
    Jul 2010
    Location
    Bend OR
    Posts
    1,257
    +1
    1
    I had a guy wanting to buy one from me and saw it had a small crack in it. So he past on buying it .It was a mater of time before it went out he said. He told me that he had 4 of them crack and try to fix them by taking them apart and said no luck. Maybe someone had better luck.

  4. #4
    demian5's Avatar
    Join Date
    May 2012
    Location
    Lake Forest, CA
    Posts
    152
    +1
    4
    I've fixed car gauges so maybe its time for me to learn something new.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Has anyone ever tried to repair their own EMM?
    By j4bs4209333 in forum Kawasaki Open Discussion
    Replies: 5
    Last Post: 09-07-2013, 08:51 AM
  2. Has anyone ever rebuilt a crank before?? or repaired one??
    By jarcynvicnchris93 in forum Kawasaki How To & FAQs
    Replies: 1
    Last Post: 04-01-2008, 07:00 PM
  3. Has anyone ever filled in the two outer channels on an R & D plate?
    By onefastgp in forum Yamaha PWC Performance (2-stroke)
    Replies: 10
    Last Post: 09-26-2006, 08:01 AM
  4. Has anyone ever used their fire extinguisher?
    By Pistonwash in forum Yamaha Open Discussion
    Replies: 18
    Last Post: 03-04-2006, 11:30 AM
  5. Has anyone ever hacked a BUDS System?
    By 1 FAST VE in forum 4-Tec Performance
    Replies: 1
    Last Post: 08-08-2005, 09:43 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •