Page 1 of 2 12 LastLast
Results 1 to 10 of 18
  1. #1
    Moderator Franko's Avatar
    Join Date
    Apr 2005
    Location
    Dallas, Texas
    Posts
    3,829
    +1
    2

    What do You Think

    of my wear ring? Bearing problem?
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	100_0557_174.jpg 
Views:	43 
Size:	673.8 KB 
ID:	1125   Click image for larger version. 

Name:	100_0555_155.jpg 
Views:	42 
Size:	641.2 KB 
ID:	1126   Click image for larger version. 

Name:	100_0554_128.jpg 
Views:	43 
Size:	541.4 KB 
ID:	1127  


  2. #2
    Top banana's Avatar
    Join Date
    Sep 2005
    Location
    Sittingbourne United Kingdon
    Posts
    753
    +1
    1
    Whats the prop like

  3. #3
    captain obvious Lurker's Avatar
    Join Date
    Jul 2005
    Location
    Visalia, Ca
    Posts
    2,316
    GP posted some pics over at .net a while back showing a bunch of different ss wear rings doing the same thing. I believe he said one or two of them had the ppg bearing mod. One may have had the double bearing mod. He said they stopped putting them on the rxps they build because of that burning.

  4. #4
    R.I.P. 11's Avatar
    Join Date
    Apr 2005
    Location
    Santa Monika, People's Republik of Kalifornia...
    Posts
    1,571
    +1
    1
    Either the single stock bearing (assuming that's what you got) can't handle the stress that comes from your modded motor or you're misaligned.

    If you're perfectly aligned in your garage then you need to give Glen Perry a call (Glen at Skat Trak that is)
    11

  5. #5
    Moderator Franko's Avatar
    Join Date
    Apr 2005
    Location
    Dallas, Texas
    Posts
    3,829
    +1
    2
    The prop is rough around the edges, but looks much better than the wear ring.

  6. #6
    Moderator Franko's Avatar
    Join Date
    Apr 2005
    Location
    Dallas, Texas
    Posts
    3,829
    +1
    2
    I have the single bearing set up. I am going to send the pump out for the double bearing (maybe triple) set up.

  7. #7
    Top banana's Avatar
    Join Date
    Sep 2005
    Location
    Sittingbourne United Kingdon
    Posts
    753
    +1
    1
    that burn mark was it at the bottom of the wear ring when in situ

  8. #8
    R.I.P. 11's Avatar
    Join Date
    Apr 2005
    Location
    Santa Monika, People's Republik of Kalifornia...
    Posts
    1,571
    +1
    1
    Quote Originally Posted by Top banana
    that burn mark was it at the bottom of the wear ring when in situ
    I was about to ask that, if it was then it's the single bearing's fault.

  9. #9
    Moderator Franko's Avatar
    Join Date
    Apr 2005
    Location
    Dallas, Texas
    Posts
    3,829
    +1
    2
    Quote Originally Posted by Top banana
    that burn mark was it at the bottom of the wear ring when in situ
    Yes.

    Here is a quick "how to" on getting the SS wear ring out. Take a dremel with a cutting attachment and make inscisions to the side lip of the wear ring big enough to fit the tip of a screwdriver. Take a screwdriver and a piece of metal as a fulcrum and pry the wear ring up. Once you get it up some, turn the pump over, place one of the pump support fittings on the edge of a work bench. Use a long screwdriver and a hammer to tap the wear ring out from the back.

  10. #10
    Top banana's Avatar
    Join Date
    Sep 2005
    Location
    Sittingbourne United Kingdon
    Posts
    753
    +1
    1
    OR drill 1/8 holes oposite in the wear ring tap a thread fit two bolts with a plate and slide hammer it out.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. What do you think after looking at this picture?
    By WATER BONER in forum Open Discussion
    Replies: 45
    Last Post: 09-10-2006, 09:30 PM
  2. Riva Vortech S/C impeller What do you think?
    By RXPNJ in forum 4-Tec Performance
    Replies: 2
    Last Post: 05-24-2006, 08:07 PM
  3. what do you think?
    By iamtwisted in forum Yamaha Open Discussion
    Replies: 7
    Last Post: 03-05-2006, 04:02 PM
  4. What do you think of these carbs?
    By idizzy in forum Yamaha PWC Performance (2-stroke)
    Replies: 22
    Last Post: 02-21-2006, 09:30 PM
  5. What do you think about the new thermostat from RIVA?
    By Therock in forum 4-Tec Performance
    Replies: 8
    Last Post: 10-01-2005, 12:38 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •