Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 30
  1. #1

    2003 Virage i - hard to start, runs poor

    when i would release the start button engine shuts off. i replaced the lr module now it will run after you try starting 5- 10 times but rough idle and poor rev up, plugs are jet black. (new plugs) any help would be great!
    Last edited by K447; 04-01-2013 at 09:56 PM.


  2. #2
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    First try unplugging the TPS and see if it will start and idle. It will not respond to throttle that way though.

  3. #3

    03 virage i hard to start runs poor

    when i would release the start button the eng, would shut off i replaced the lr module now it will start after 5-10 times (will still die when i release the
    button then it will start) runs rough plugs are jet black any help would be
    great!

  4. #4
    thanks i cant try tonight but will first thing tomorrow

  5. #5
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,589
    +1
    1,272
    You can bypass the LR Start/Stop module for testing. Details via my signature links.

    Has the TPS on the throttle body been changed? If you unplug the TPS does the engine start easily and then idle at a steady RPM?

    Have you checked the voltage on the White/Red wire that feeds the injectors? This must be done with both injectors plugged in. Voltage while cranking should be over 20 volts.

  6. #6
    i have over 20 volts on white/red wire. when i unplug the tps it will not start.

  7. #7
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,589
    +1
    1,272
    Quote Originally Posted by K447 View Post
    You can bypass the LR Start/Stop module for testing. Details via my signature links.

    Has the TPS on the throttle body been changed? ...

    ... voltage on the White/Red wire that feeds the injectors? This must be done with both injectors plugged in. ...
    ?

  8. #8
    not sure if the tps has been changed i ck, your bypass of the start stop pushed bilge button
    while cranking still doesn't want to start takes 5-10 times then it starts (there is no spark when you release the start button)

  9. #9
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,589
    +1
    1,272
    Quote Originally Posted by larry180 View Post
    ... bypass of the start stop pushed bilge button
    while cranking
    still doesn't want to start takes 5-10 times then it starts (there is no spark when you release the start button)
    The LR-503 Start/Stop module bypass for the carburetor engine is not exactly the same as for the Ficht engine. The Bilge button does not affect starting in the Ficht bypass arrangement.

    The 'spark only when Start button' is released is also a carburetor engine only symptom.

  10. #10
    what could cause it to have spark only when you push the button, then have spark and start when you push and release the button.the running poor might be part of the problem?

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2003 Virage i - hard to start, runs poor
    By larry180 in forum Polaris Open Discussion
    Replies: 1
    Last Post: 04-01-2013, 09:54 PM
  2. Polaris virage txi hard to start
    By arqjorgelg in forum Polaris Open Discussion
    Replies: 11
    Last Post: 08-28-2012, 09:24 AM
  3. 2001 Polaris Virage TXi hard to start when hot
    By clboyte in forum Polaris Open Discussion
    Replies: 10
    Last Post: 06-20-2011, 09:00 PM
  4. Ski hard to start and runing poorly
    By Mowerpan in forum 2-Stroke Performance
    Replies: 3
    Last Post: 04-02-2008, 08:43 AM
  5. Virage TX hard to start
    By pirate33 in forum Polaris How To & FAQs
    Replies: 23
    Last Post: 07-21-2007, 08:58 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •